summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/djangorestframework/djangorestframework-3.9.2.ebuild')
-rw-r--r--dev-python/djangorestframework/djangorestframework-3.9.2.ebuild19
1 files changed, 19 insertions, 0 deletions
diff --git a/dev-python/djangorestframework/djangorestframework-3.9.2.ebuild b/dev-python/djangorestframework/djangorestframework-3.9.2.ebuild
new file mode 100644
index 000000000000..745e84b017a7
--- /dev/null
+++ b/dev-python/djangorestframework/djangorestframework-3.9.2.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} )
+inherit distutils-r1
+
+DESCRIPTION="Web APIs with django made easy"
+HOMEPAGE="https://www.django-rest-framework.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND=">=dev-python/django-1.11[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+dev-python/setuptools[${PYTHON_USEDEP}]"