summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/dkimpy/dkimpy-1.0.5.ebuild')
-rw-r--r--dev-python/dkimpy/dkimpy-1.0.5.ebuild36
1 files changed, 0 insertions, 36 deletions
diff --git a/dev-python/dkimpy/dkimpy-1.0.5.ebuild b/dev-python/dkimpy/dkimpy-1.0.5.ebuild
deleted file mode 100644
index 818fd1ed2206..000000000000
--- a/dev-python/dkimpy/dkimpy-1.0.5.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 2020-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7,8,9} )
-DISTUTILS_USE_SETUPTOOLS=rdepend
-
-inherit distutils-r1 optfeature
-
-DESCRIPTION="DKIM and ARC email signing and verification library"
-HOMEPAGE="https://launchpad.net/dkimpy"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 arm64 x86"
-
-RDEPEND="
- dev-python/dnspython[${PYTHON_USEDEP}]
-"
-
-distutils_enable_tests unittest
-
-BDEPEND+="
- test? (
- dev-python/authres[${PYTHON_USEDEP}]
- dev-python/pynacl[${PYTHON_USEDEP}]
- )
-"
-
-pkg_postinst() {
- optfeature "ARC support" dev-python/authres
- optfeature "ed25519 capability" dev-python/pynacl
- optfeature "asyncio support" dev-python/aiodns
-}