summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/dominate/dominate-2.3.1.ebuild')
-rw-r--r--dev-python/dominate/dominate-2.3.1.ebuild11
1 files changed, 4 insertions, 7 deletions
diff --git a/dev-python/dominate/dominate-2.3.1.ebuild b/dev-python/dominate/dominate-2.3.1.ebuild
index d149b940eab5..a66dafe92b1a 100644
--- a/dev-python/dominate/dominate-2.3.1.ebuild
+++ b/dev-python/dominate/dominate-2.3.1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+EAPI=7
+PYTHON_COMPAT=( pypy{,3} python{2_7,3_{4,5,6}} )
inherit distutils-r1
@@ -17,10 +17,7 @@ IUSE="test"
DEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/pytest-runner[${PYTHON_USEDEP}]
- )
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
"
python_test() {