summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/dominate/dominate-2.4.0.ebuild')
-rw-r--r--dev-python/dominate/dominate-2.4.0.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/dominate/dominate-2.4.0.ebuild b/dev-python/dominate/dominate-2.4.0.ebuild
new file mode 100644
index 000000000000..1b6ca3ac3a8d
--- /dev/null
+++ b/dev-python/dominate/dominate-2.4.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( pypy{,3} python{2_7,3_{5,6,7}} )
+
+inherit distutils-r1
+
+DESCRIPTION="Library for creating and manipulating HTML documents using an elegant DOM API"
+HOMEPAGE="https://github.com/Knio/dominate"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+BDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+"
+
+python_test() {
+ pytest -vv || die "Tests failed with ${EPYTHON}"
+}