summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/dpkt/dpkt-1.8-r1.ebuild')
-rw-r--r--dev-python/dpkt/dpkt-1.8-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/dpkt/dpkt-1.8-r1.ebuild b/dev-python/dpkt/dpkt-1.8-r1.ebuild
new file mode 100644
index 000000000000..17d304cddba8
--- /dev/null
+++ b/dev-python/dpkt/dpkt-1.8-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Fast, simple packet creation / parsing, with definitions for the basic TCP/IP protocols"
+HOMEPAGE="http://code.google.com/p/dpkt/"
+SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="examples"
+
+DEPEND=""
+RDEPEND=""
+
+DOCS=( AUTHORS CHANGES HACKING )
+
+python_test() {
+ "${PYTHON}" tests/test-perf2.py || die
+}
+
+src_install() {
+ distutils-r1_src_install
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}