summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/easyprocess/easyprocess-0.3.ebuild')
-rw-r--r--dev-python/easyprocess/easyprocess-0.3.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/easyprocess/easyprocess-0.3.ebuild b/dev-python/easyprocess/easyprocess-0.3.ebuild
new file mode 100644
index 000000000000..c1b10718a56c
--- /dev/null
+++ b/dev-python/easyprocess/easyprocess-0.3.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Easy to use Python subprocess interface"
+HOMEPAGE="https://github.com/ponty/EasyProcess"
+SRC_URI="https://github.com/ponty/EasyProcess/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="test? (
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ dev-python/pyvirtualdisplay[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+)"
+
+S="${WORKDIR}/EasyProcess-${PV}"
+
+distutils_enable_tests pytest