summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/editorconfig-core-py')
-rw-r--r--dev-python/editorconfig-core-py/Manifest1
-rw-r--r--dev-python/editorconfig-core-py/editorconfig-core-py-0.12.3.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/editorconfig-core-py/Manifest b/dev-python/editorconfig-core-py/Manifest
index 2b84215896ed..5034dc7bbd9f 100644
--- a/dev-python/editorconfig-core-py/Manifest
+++ b/dev-python/editorconfig-core-py/Manifest
@@ -1,2 +1,3 @@
DIST editorconfig-core-py-0.12.0.tar.gz 24801 BLAKE2B 10901b1595965139dbc3aa3227f335c2128b2ea83204ed88b0e799021f7c215fd13c3e2246cb9197ecb7c918aca2d6e9269d94298aa0665432ab091630a29dd6 SHA512 29c5f58bd7293052e4b1fbfbadcf4a148eb939558494d599bafd46151a4fb5af9cd07dcef477db9a709a0ea63dec0dd7e9d4071779f8ca6e3bd137268cc22f72
+DIST editorconfig-core-py-0.12.3.tar.gz 19261 BLAKE2B 58cac122cfee19527bc45def7e923da50982de0e2cd443cf67dd824c050fb12352b85a5679815a701bc5b8d88a089a0a98280c364730086d01b80f119ad996a4 SHA512 005d0698c410c8865d177a1e891b5c51b15255f36303b116fddbbbc08e309d1d60ca3003d27e6fd8455e53c5956db0c29e298f22f4b10950e1f7c56c7c6e0ab3
DIST editorconfig-core-test-abb579e00f2deeede91cb485e53512efab9c6474.tar.gz 7900 BLAKE2B 9ebdb5e522948bc9e86ea84435ccaa11585a8a12f4cd6fe54c64d78917281c913568351767d8077623b1196d84206d1c2d0126a0510f70df484c1b55d829028b SHA512 ae5424b4926d6cb127cb3da473400ced4f7ccf224f7baa8bc5bde0317cc045bb7b99738a56efe5fd0e5a0fbe39b997b9fb1739d24713e7f83b58e987c5e56a32
diff --git a/dev-python/editorconfig-core-py/editorconfig-core-py-0.12.3.ebuild b/dev-python/editorconfig-core-py/editorconfig-core-py-0.12.3.ebuild
new file mode 100644
index 000000000000..1c0da663b099
--- /dev/null
+++ b/dev-python/editorconfig-core-py/editorconfig-core-py-0.12.3.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{6..9} )
+inherit cmake distutils-r1
+
+TESTVER="abb579e00f2deeede91cb485e53512efab9c6474"
+DESCRIPTION="Clone of EditorConfig core written in Python"
+HOMEPAGE="https://editorconfig.org/"
+SRC_URI="https://github.com/${PN%-core-py}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ test? (
+ https://github.com/${PN%-core-py}/${PN%-core-py}-core-test/archive/${TESTVER}.tar.gz -> ${PN%-core-py}-core-test-${TESTVER}.tar.gz
+ )"
+
+LICENSE="PYTHON BSD-4"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="!<app-vim/editorconfig-vim-0.3.3-r1"
+
+src_prepare() {
+ if use test; then
+ mv "${WORKDIR}"/${PN%-core-py}-core-test-${TESTVER}/* "${S}"/tests || die
+ fi
+
+ cmake_src_prepare
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local mycmakeargs=(
+ -DPYTHON_EXECUTABLE="${PYTHON}"
+ )
+
+ cmake_src_configure
+ cmake_src_compile
+ cmake_src_test
+}