summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/emoji/emoji-2.4.0.ebuild')
-rw-r--r--dev-python/emoji/emoji-2.4.0.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/emoji/emoji-2.4.0.ebuild b/dev-python/emoji/emoji-2.4.0.ebuild
new file mode 100644
index 000000000000..db91ef152e72
--- /dev/null
+++ b/dev-python/emoji/emoji-2.4.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Emoji for Python"
+HOMEPAGE="
+ https://github.com/carpedm20/emoji/
+ https://pypi.org/project/emoji/
+"
+SRC_URI="
+ https://github.com/carpedm20/emoji/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64"
+
+distutils_enable_tests pytest