summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/enrich/enrich-1.2.7-r1.ebuild')
-rw-r--r--dev-python/enrich/enrich-1.2.7-r1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/enrich/enrich-1.2.7-r1.ebuild b/dev-python/enrich/enrich-1.2.7-r1.ebuild
new file mode 100644
index 000000000000..40e7e19b5be2
--- /dev/null
+++ b/dev-python/enrich/enrich-1.2.7-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Extend rich functionality"
+HOMEPAGE="
+ https://github.com/pycontribs/enrich/
+ https://pypi.org/project/enrich/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/rich[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # known breakage in dev-python/rich
+ # https://github.com/Textualize/rich/issues/2172
+ # https://github.com/pycontribs/enrich/issues/40
+ src/enrich/test/test_console.py::test_rich_console_ex
+)