summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/eventlet')
-rw-r--r--dev-python/eventlet/Manifest4
-rw-r--r--dev-python/eventlet/eventlet-0.30.0-r1.ebuild64
-rw-r--r--dev-python/eventlet/eventlet-0.30.2-r1.ebuild66
-rw-r--r--dev-python/eventlet/eventlet-0.31.0.ebuild66
-rw-r--r--dev-python/eventlet/eventlet-0.31.1.ebuild52
-rw-r--r--dev-python/eventlet/files/eventlet-0.25.1-tests.patch40
-rw-r--r--dev-python/eventlet/files/eventlet-0.30.0-tests-socket.patch13
-rw-r--r--dev-python/eventlet/files/eventlet-0.30.2-test-timeout.patch39
-rw-r--r--dev-python/eventlet/metadata.xml12
9 files changed, 0 insertions, 356 deletions
diff --git a/dev-python/eventlet/Manifest b/dev-python/eventlet/Manifest
deleted file mode 100644
index 283f64d93c09..000000000000
--- a/dev-python/eventlet/Manifest
+++ /dev/null
@@ -1,4 +0,0 @@
-DIST eventlet-0.30.0.tar.gz 401035 BLAKE2B 94a272ce810b28c00fc8a468f160e38f3c58c98750455e5eb096c266c46257a7e30e0278a6a8f509e47e6ab40297129ccf52b347a723037f9cc9b85a3e06a203 SHA512 c2ba283063333e9e74536dcda33276f98f74051ea0e9c8669506d2e3b11715f37cd5963af6130f14761a42cc6c8346e59c756efe2cef0ea3547dc30ccb8bf0fb
-DIST eventlet-0.30.2.tar.gz 401552 BLAKE2B 89291efde90d106a96eebd4ea4a892eeb005d6850262b28f7a4508f4f3ccfb9b49dc392dcb6eb0cf20c5d171d26d2a6639627188c97123546162e4e8c61c464d SHA512 af31a7b126f2120dd77699dcf25c7134af1bcf664f40b2422238a3d2120457d5a4d5764e23016ce209882a8b888f94d2776fe194c33092f4a33111b2ac8f0cf1
-DIST eventlet-0.31.0.tar.gz 402530 BLAKE2B d4d5983b22d04fbd6102b7e1ebe58c6e23cba04968478808445d946a3d8fc9ee0b668e83321397163d507cacf58f0cdd8547b0fb2649bad23819fbee0a6cc5ad SHA512 1721ec5d3c6c02361a5993237426d0466d87327e3d429d7b9f20d3466eebf08c60e57a2b1ab133956fe508835e5e84c52317aa51f962e8487f22a6207bbbfcf8
-DIST eventlet-0.31.1.tar.gz 412021 BLAKE2B 6358dca8e0a766f0cc2cef37586a8d38f5d87f03d8389a7cc11b3d2d616669825df2a416ae980eed8a980f8e81ce8b2848225921bb4536f5537a7954ed75fb64 SHA512 c240a332aaf8eeb4af429d1b190ae198b4bcb92ae1bc38ade3f824634327872526267c6ff02f7196e3f9dfd17d639af500c28a3ed70a773b1b050d6d967a88a5
diff --git a/dev-python/eventlet/eventlet-0.30.0-r1.ebuild b/dev-python/eventlet/eventlet-0.30.0-r1.ebuild
deleted file mode 100644
index 4e937ab0a086..000000000000
--- a/dev-python/eventlet/eventlet-0.30.0-r1.ebuild
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7,8,9} )
-inherit distutils-r1
-
-DESCRIPTION="Highly concurrent networking library"
-HOMEPAGE="https://pypi.org/project/eventlet/ https://github.com/eventlet/eventlet/"
-SRC_URI="mirror://pypi/e/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ppc ppc64 ~s390 sparc x86"
-IUSE="doc examples test"
-
-RDEPEND="
- >=dev-python/dnspython-1.15.0[${PYTHON_USEDEP}]
- <dev-python/dnspython-2.0.0[${PYTHON_USEDEP}]
- >=dev-python/greenlet-0.3[${PYTHON_USEDEP}]
- >=dev-python/six-1.10.0[${PYTHON_USEDEP}]"
-DEPEND="doc? ( >=dev-python/python-docs-2.7.6-r1:2.7 )
- test? ( ${RDEPEND}
- dev-python/pyopenssl[${PYTHON_USEDEP}]
- dev-python/nose[${PYTHON_USEDEP}] )"
-
-PATCHES=(
- "${FILESDIR}/${PN}-0.25.1-tests.patch"
- "${FILESDIR}/${PN}-0.30.0-tests-socket.patch"
-)
-
-distutils_enable_sphinx doc
-distutils_enable_tests nose
-
-python_prepare_all() {
- if use doc; then
- local PYTHON_DOC_ATOM=$(best_version -b dev-python/python-docs:2.7)
- local PYTHON_DOC_VERSION="${PYTHON_DOC_ATOM#dev-python/python-docs-}"
- local PYTHON_DOC="/usr/share/doc/python-docs-${PYTHON_DOC_VERSION}/html"
- local PYTHON_DOC_INVENTORY="${PYTHON_DOC}/objects.inv"
- sed -i "s|'https://docs.python.org/': None|'${PYTHON_DOC}': '${PYTHON_DOC_INVENTORY}'|" doc/conf.py || die
- fi
-
- # Prevent file collisions from teestsuite
- sed -e "s:'tests', :'tests', 'tests.*', :" -i setup.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- unset PYTHONPATH
- export TMPDIR="${T}"
- nosetests -v || die
-}
-
-python_install_all() {
- if use examples; then
- docompress -x "/usr/share/doc/${PF}/examples"
- docinto examples
- dodoc -r examples/.
- fi
- distutils-r1_python_install_all
-}
diff --git a/dev-python/eventlet/eventlet-0.30.2-r1.ebuild b/dev-python/eventlet/eventlet-0.30.2-r1.ebuild
deleted file mode 100644
index c335ba582bb7..000000000000
--- a/dev-python/eventlet/eventlet-0.30.2-r1.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..9} )
-inherit distutils-r1
-
-DESCRIPTION="Highly concurrent networking library"
-HOMEPAGE="https://pypi.org/project/eventlet/ https://github.com/eventlet/eventlet/"
-SRC_URI="mirror://pypi/e/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 ppc ~ppc64 ~s390 ~sparc x86"
-IUSE="doc examples"
-
-RDEPEND="
- >=dev-python/dnspython-1.15.0[${PYTHON_USEDEP}]
- <dev-python/dnspython-2.0.0[${PYTHON_USEDEP}]
- >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
- virtual/python-greenlet[${PYTHON_USEDEP}]
-"
-BDEPEND="
- doc? ( >=dev-python/python-docs-2.7.6-r1:2.7 )
- test? (
- dev-python/pyopenssl[${PYTHON_USEDEP}]
- )
-"
-
-PATCHES=(
- "${FILESDIR}/eventlet-0.25.1-tests.patch"
- "${FILESDIR}/eventlet-0.30.0-tests-socket.patch"
- "${FILESDIR}/eventlet-0.30.2-test-timeout.patch"
-)
-
-distutils_enable_sphinx doc
-distutils_enable_tests nose
-
-python_prepare_all() {
- if use doc; then
- local PYTHON_DOC_ATOM=$(best_version -b dev-python/python-docs:2.7)
- local PYTHON_DOC_VERSION="${PYTHON_DOC_ATOM#dev-python/python-docs-}"
- local PYTHON_DOC="/usr/share/doc/python-docs-${PYTHON_DOC_VERSION}/html"
- local PYTHON_DOC_INVENTORY="${PYTHON_DOC}/objects.inv"
- sed -i "s|'https://docs.python.org/': None|'${PYTHON_DOC}': '${PYTHON_DOC_INVENTORY}'|" doc/conf.py || die
- fi
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- unset PYTHONPATH
- export TMPDIR="${T}"
- nosetests -v -x || die
-}
-
-python_install_all() {
- if use examples; then
- docompress -x "/usr/share/doc/${PF}/examples"
- docinto examples
- dodoc -r examples/.
- fi
-
- distutils-r1_python_install_all
-}
diff --git a/dev-python/eventlet/eventlet-0.31.0.ebuild b/dev-python/eventlet/eventlet-0.31.0.ebuild
deleted file mode 100644
index cc5799f48b25..000000000000
--- a/dev-python/eventlet/eventlet-0.31.0.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..9} )
-inherit distutils-r1
-
-DESCRIPTION="Highly concurrent networking library"
-HOMEPAGE="https://pypi.org/project/eventlet/ https://github.com/eventlet/eventlet/"
-SRC_URI="mirror://pypi/e/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 arm ~arm64 ppc ~ppc64 ~s390 ~sparc x86"
-IUSE="doc examples"
-
-RDEPEND="
- >=dev-python/dnspython-1.15.0[${PYTHON_USEDEP}]
- <dev-python/dnspython-2.0.0[${PYTHON_USEDEP}]
- >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
- virtual/python-greenlet[${PYTHON_USEDEP}]
-"
-BDEPEND="
- doc? ( >=dev-python/python-docs-2.7.6-r1:2.7 )
- test? (
- dev-python/pyopenssl[${PYTHON_USEDEP}]
- )
-"
-
-PATCHES=(
- "${FILESDIR}/eventlet-0.25.1-tests.patch"
- "${FILESDIR}/eventlet-0.30.0-tests-socket.patch"
- "${FILESDIR}/eventlet-0.30.2-test-timeout.patch"
-)
-
-distutils_enable_sphinx doc
-distutils_enable_tests nose
-
-python_prepare_all() {
- if use doc; then
- local PYTHON_DOC_ATOM=$(best_version -b dev-python/python-docs:2.7)
- local PYTHON_DOC_VERSION="${PYTHON_DOC_ATOM#dev-python/python-docs-}"
- local PYTHON_DOC="/usr/share/doc/python-docs-${PYTHON_DOC_VERSION}/html"
- local PYTHON_DOC_INVENTORY="${PYTHON_DOC}/objects.inv"
- sed -i "s|'https://docs.python.org/': None|'${PYTHON_DOC}': '${PYTHON_DOC_INVENTORY}'|" doc/conf.py || die
- fi
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- unset PYTHONPATH
- export TMPDIR="${T}"
- nosetests -v -x || die
-}
-
-python_install_all() {
- if use examples; then
- docompress -x "/usr/share/doc/${PF}/examples"
- docinto examples
- dodoc -r examples/.
- fi
-
- distutils-r1_python_install_all
-}
diff --git a/dev-python/eventlet/eventlet-0.31.1.ebuild b/dev-python/eventlet/eventlet-0.31.1.ebuild
deleted file mode 100644
index 3fc34d0e705d..000000000000
--- a/dev-python/eventlet/eventlet-0.31.1.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..9} )
-inherit distutils-r1
-
-DESCRIPTION="Highly concurrent networking library"
-HOMEPAGE="https://pypi.org/project/eventlet/ https://github.com/eventlet/eventlet/"
-SRC_URI="mirror://pypi/e/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
-IUSE="examples"
-
-RDEPEND="
- >=dev-python/dnspython-1.15.0[${PYTHON_USEDEP}]
- <dev-python/dnspython-2.0.0[${PYTHON_USEDEP}]
- >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
- virtual/python-greenlet[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/pyopenssl[${PYTHON_USEDEP}]
- )
-"
-
-PATCHES=(
- "${FILESDIR}/eventlet-0.25.1-tests.patch"
- "${FILESDIR}/eventlet-0.30.0-tests-socket.patch"
- "${FILESDIR}/eventlet-0.30.2-test-timeout.patch"
-)
-
-distutils_enable_tests nose
-
-python_test() {
- unset PYTHONPATH
- export TMPDIR="${T}"
- nosetests -v -x || die
-}
-
-python_install_all() {
- if use examples; then
- docompress -x "/usr/share/doc/${PF}/examples"
- docinto examples
- dodoc -r examples/.
- fi
-
- distutils-r1_python_install_all
-}
diff --git a/dev-python/eventlet/files/eventlet-0.25.1-tests.patch b/dev-python/eventlet/files/eventlet-0.25.1-tests.patch
deleted file mode 100644
index 423f8ef8e408..000000000000
--- a/dev-python/eventlet/files/eventlet-0.25.1-tests.patch
+++ /dev/null
@@ -1,40 +0,0 @@
-diff --git a/tests/ssl_test.py b/tests/ssl_test.py
-index d8b7d7e..5a3580b 100644
---- a/tests/ssl_test.py
-+++ b/tests/ssl_test.py
-@@ -180,7 +180,6 @@ class SSLTest(tests.LimitedTestCase):
- self.assertEqual(client.recv(8), b'response')
- stage_1.send()
-
-- tests.check_idle_cpu_usage(0.2, 0.1)
- server_coro.kill()
-
- def test_greensslobject(self):
-diff --git a/tests/zmq_test.py b/tests/zmq_test.py
-index 601878f..c643e48 100644
---- a/tests/zmq_test.py
-+++ b/tests/zmq_test.py
-@@ -432,6 +432,8 @@ class TestUpstreamDownStream(tests.LimitedTestCase):
- events = sock2.getsockopt(zmq.EVENTS)
- self.assertEqual(events & zmq.POLLIN, zmq.POLLIN)
-
-+ # this will often fail on portage...
-+ @tests.skip_if(True)
- @tests.skip_unless(zmq_supported)
- def test_cpu_usage_after_bind(self):
- """zmq eats CPU after PUB socket .bind()
-@@ -461,14 +463,12 @@ class TestUpstreamDownStream(tests.LimitedTestCase):
- sub.setsockopt(zmq.SUBSCRIBE, b"")
- eventlet.sleep()
- pub.send(b'test_send')
-- tests.check_idle_cpu_usage(0.2, 0.1)
-
- sender, receiver, _port = self.create_bound_pair(zmq.DEALER, zmq.DEALER)
- eventlet.sleep()
- sender.send(b'test_recv')
- msg = receiver.recv()
- self.assertEqual(msg, b'test_recv')
-- tests.check_idle_cpu_usage(0.2, 0.1)
-
-
- class TestQueueLock(tests.LimitedTestCase):
diff --git a/dev-python/eventlet/files/eventlet-0.30.0-tests-socket.patch b/dev-python/eventlet/files/eventlet-0.30.0-tests-socket.patch
deleted file mode 100644
index 4dd309c68a38..000000000000
--- a/dev-python/eventlet/files/eventlet-0.30.0-tests-socket.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-Let's use TMPDIR as the base for this test's unix socket to help it pass.
-We set TMPDIR in the ebuild to ${T}.
---- a/tests/backdoor_test.py
-+++ b/tests/backdoor_test.py
-@@ -47,7 +47,7 @@ class BackdoorTest(tests.LimitedTestCase):
- self._run_test_on_client_and_server(client, serv)
-
- def test_server_on_unix_socket(self):
-- SOCKET_PATH = '/tmp/eventlet_backdoor_test.socket'
-+ SOCKET_PATH = os.getenv('TMPDIR', '/tmp') + '/eventlet_backdoor_test.socket'
- if os.path.exists(SOCKET_PATH):
- os.unlink(SOCKET_PATH)
- listener = socket.socket(socket.AF_UNIX)
diff --git a/dev-python/eventlet/files/eventlet-0.30.2-test-timeout.patch b/dev-python/eventlet/files/eventlet-0.30.2-test-timeout.patch
deleted file mode 100644
index d31b3738bc16..000000000000
--- a/dev-python/eventlet/files/eventlet-0.30.2-test-timeout.patch
+++ /dev/null
@@ -1,39 +0,0 @@
-From 0b8fd069386354d2d7e5464ce0b0d5b7d1795376 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
-Date: Sun, 11 Apr 2021 12:20:09 +0200
-Subject: [PATCH] Force test timeouts to 60 s
-
-The upstream test timeouts are far too low for a busy system, and there
-is no point in pursuing such low values anyway. Force 60 s that should
-be reasonably safe for our test runs.
----
- tests/__init__.py | 6 +++---
- 1 file changed, 3 insertions(+), 3 deletions(-)
-
-diff --git a/tests/__init__.py b/tests/__init__.py
-index 82cd247..3a943c4 100644
---- a/tests/__init__.py
-+++ b/tests/__init__.py
-@@ -170,8 +170,8 @@ class LimitedTestCase(unittest.TestCase):
-
- def setUp(self):
- self.previous_alarm = None
-- self.timer = eventlet.Timeout(self.TEST_TIMEOUT,
-- TestIsTakingTooLong(self.TEST_TIMEOUT))
-+ self.timer = eventlet.Timeout(60,
-+ TestIsTakingTooLong(60))
-
- def reset_timeout(self, new_timeout):
- """Changes the timeout duration; only has effect during one test.
-@@ -350,7 +350,7 @@ def run_python(path, env=None, args=None, timeout=None, pythonpath_extend=None,
- stdout=subprocess.PIPE,
- )
- if timeout is None:
-- timeout = 10
-+ timeout = 60
- try:
- output, _ = p.communicate(timeout=timeout)
- except subprocess.TimeoutExpired:
---
-2.31.1
-
diff --git a/dev-python/eventlet/metadata.xml b/dev-python/eventlet/metadata.xml
deleted file mode 100644
index 6cec5e8a7b6c..000000000000
--- a/dev-python/eventlet/metadata.xml
+++ /dev/null
@@ -1,12 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>python@gentoo.org</email>
- <name>Python</name>
- </maintainer>
- <upstream>
- <remote-id type="pypi">eventlet</remote-id>
- <remote-id type="github">eventlet/eventlet</remote-id>
- </upstream>
-</pkgmetadata>