summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/exceptiongroup/exceptiongroup-1.1.3.ebuild')
-rw-r--r--dev-python/exceptiongroup/exceptiongroup-1.1.3.ebuild36
1 files changed, 0 insertions, 36 deletions
diff --git a/dev-python/exceptiongroup/exceptiongroup-1.1.3.ebuild b/dev-python/exceptiongroup/exceptiongroup-1.1.3.ebuild
deleted file mode 100644
index c06238b9a508..000000000000
--- a/dev-python/exceptiongroup/exceptiongroup-1.1.3.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 2022-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=flit_scm
-PYTHON_COMPAT=( pypy3 python3_{10..12} )
-
-inherit distutils-r1
-
-MY_P=${P/_}
-DESCRIPTION="Backport of PEP 654 (exception groups)"
-HOMEPAGE="
- https://github.com/agronholm/exceptiongroup/
- https://pypi.org/project/exceptiongroup/
-"
-# pypi sdist does not include tests as of 1.1.1
-# https://github.com/agronholm/exceptiongroup/pull/59
-SRC_URI="
- https://github.com/agronholm/exceptiongroup/archive/${PV/_}.tar.gz
- -> ${MY_P}.gh.tar.gz
-"
-S=${WORKDIR}/${MY_P}
-
-LICENSE="MIT PSF-2.4"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-
-distutils_enable_tests pytest
-
-export SETUPTOOLS_SCM_PRETEND_VERSION=${PV/_}
-
-python_test() {
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- epytest
-}