summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/exceptiongroup/exceptiongroup-1.2.1.ebuild')
-rw-r--r--dev-python/exceptiongroup/exceptiongroup-1.2.1.ebuild12
1 files changed, 11 insertions, 1 deletions
diff --git a/dev-python/exceptiongroup/exceptiongroup-1.2.1.ebuild b/dev-python/exceptiongroup/exceptiongroup-1.2.1.ebuild
index 67c66ba7616b..112639c10e38 100644
--- a/dev-python/exceptiongroup/exceptiongroup-1.2.1.ebuild
+++ b/dev-python/exceptiongroup/exceptiongroup-1.2.1.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=flit_scm
-PYTHON_COMPAT=( pypy3 python3_{10..12} )
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
inherit distutils-r1 pypi
@@ -21,6 +21,16 @@ KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv
distutils_enable_tests pytest
python_test() {
+ local EPYTEST_DESELECT=()
+ case ${EPYTHON} in
+ python3.13)
+ EPYTEST_DESELECT+=(
+ # https://github.com/agronholm/exceptiongroup/issues/122
+ tests/test_formatting.py
+ )
+ ;;
+ esac
+
local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
epytest
}