summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/exdown/exdown-0.9.0.ebuild')
-rw-r--r--dev-python/exdown/exdown-0.9.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/exdown/exdown-0.9.0.ebuild b/dev-python/exdown/exdown-0.9.0.ebuild
new file mode 100644
index 000000000000..c1f7fb4961a0
--- /dev/null
+++ b/dev-python/exdown/exdown-0.9.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1 virtualx
+
+MY_P=pytest-codeblocks-${PV}
+DESCRIPTION="Extract code blocks from markdown"
+HOMEPAGE="https://github.com/nschloe/pytest-codeblocks/"
+SRC_URI="
+ https://github.com/nschloe/pytest-codeblocks/archive/v${PV}.tar.gz
+ -> ${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/importlib_metadata[${PYTHON_USEDEP}]
+ ' python3_7)
+"
+
+distutils_enable_tests pytest