summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/executing')
-rw-r--r--dev-python/executing/Manifest3
-rw-r--r--dev-python/executing/executing-0.6.0.ebuild37
-rw-r--r--dev-python/executing/executing-0.7.0.ebuild37
-rw-r--r--dev-python/executing/executing-2.0.1.ebuild69
-rw-r--r--dev-python/executing/files/executing-2.0.1-additional-slow-tests.patch38
-rw-r--r--dev-python/executing/metadata.xml2
6 files changed, 109 insertions, 77 deletions
diff --git a/dev-python/executing/Manifest b/dev-python/executing/Manifest
index 54651edfaafe..d2ce7ff6f380 100644
--- a/dev-python/executing/Manifest
+++ b/dev-python/executing/Manifest
@@ -1,2 +1 @@
-DIST executing-0.6.0.gh.tar.gz 330731 BLAKE2B f6a86072907c5140aefb45beb46bcc8c6e3e242e2e821046e59f0eafe1d5c16efe3c08dd1b19b1ce85388fd9cc4757bfe586b95fb490a594cfee4f5e69b5a0af SHA512 5d2f621ff4cbfd55ac43b555f771b129ade5d20f882f4e5d6a060a1a099abad73cc4128c9e6bd32fccc40c4c85c51c28b3be40ab16f163e1ceaaad07f1936ab7
-DIST executing-0.7.0.gh.tar.gz 452550 BLAKE2B 9b3bdb49b3b00ca17952db747d3f0f3995e8dffbc170bcb2260e7c34ce9e6b0c8e1620be2e2776445a6114add4e2437eaeae8a308391e2c121b6484b5bc6056c SHA512 08ee347f0bcaf04ca2c6010762a6d2d5b054b3590029c55d18d6efae5a5db7c6c5a0948cce9d9684e4bfbfd9ea19326e4ac2c96be40535c0500c28c28ce81e07
+DIST executing-2.0.1.gh.tar.gz 837355 BLAKE2B 7d38890eb322809c2b705f51731fe7537f81a0775d99bebb4b4ae67453930daedd947b249385babbc2373969344b643f288441fc28f3588264e4ebc23e1c389d SHA512 8a753aab42ea2d3b61764ee77de3bb52ea7fcc2818298281180ffc47c7b22ee84974ee98b2137250f722ad559be92e72e8fc01d7b2d38ab6a01512618b65d4f3
diff --git a/dev-python/executing/executing-0.6.0.ebuild b/dev-python/executing/executing-0.6.0.ebuild
deleted file mode 100644
index fd754d9ae943..000000000000
--- a/dev-python/executing/executing-0.6.0.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 2020-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..9} )
-inherit distutils-r1
-
-DESCRIPTION="Get information about what a Python frame is currently doing"
-HOMEPAGE="
- https://github.com/alexmojaki/executing/
- https://pypi.org/project/executing/"
-SRC_URI="
- https://github.com/alexmojaki/executing/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ~ppc ~ppc64 ~sparc x86"
-
-# asttokens is optional runtime dep
-BDEPEND="
- dev-python/setuptools_scm[${PYTHON_USEDEP}]
- dev-python/toml[${PYTHON_USEDEP}]
- test? (
- dev-python/asttokens[${PYTHON_USEDEP}]
- )"
-
-distutils_enable_tests pytest
-
-export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
-
-python_test() {
- # this test explodes when collected by pytest
- "${EPYTHON}" tests/test_main.py || die "Tests failed with ${EPYTHON}"
- pytest -vv tests/test_pytest.py || die "Tests failed with ${EPYTHON}"
-}
diff --git a/dev-python/executing/executing-0.7.0.ebuild b/dev-python/executing/executing-0.7.0.ebuild
deleted file mode 100644
index fc9d9501f8e0..000000000000
--- a/dev-python/executing/executing-0.7.0.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 2020-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..9} )
-inherit distutils-r1
-
-DESCRIPTION="Get information about what a Python frame is currently doing"
-HOMEPAGE="
- https://github.com/alexmojaki/executing/
- https://pypi.org/project/executing/"
-SRC_URI="
- https://github.com/alexmojaki/executing/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86"
-
-# asttokens is optional runtime dep
-BDEPEND="
- dev-python/setuptools_scm[${PYTHON_USEDEP}]
- dev-python/toml[${PYTHON_USEDEP}]
- test? (
- dev-python/asttokens[${PYTHON_USEDEP}]
- )"
-
-distutils_enable_tests pytest
-
-export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
-
-python_test() {
- # this test explodes when collected by pytest
- "${EPYTHON}" tests/test_main.py || die "Tests failed with ${EPYTHON}"
- epytest tests/test_pytest.py
-}
diff --git a/dev-python/executing/executing-2.0.1.ebuild b/dev-python/executing/executing-2.0.1.ebuild
new file mode 100644
index 000000000000..6bb21080f195
--- /dev/null
+++ b/dev-python/executing/executing-2.0.1.ebuild
@@ -0,0 +1,69 @@
+# Copyright 2020-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Get information about what a Python frame is currently doing"
+HOMEPAGE="
+ https://github.com/alexmojaki/executing/
+ https://pypi.org/project/executing/
+"
+SRC_URI="
+ https://github.com/alexmojaki/executing/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ppc ppc64 ~riscv ~s390 sparc x86 ~arm64-macos ~x64-macos"
+
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/asttokens-2.1.0[${PYTHON_USEDEP}]
+ dev-python/littleutils[${PYTHON_USEDEP}]
+ dev-python/rich[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-2.0.1-additional-slow-tests.patch"
+)
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+
+python_test() {
+ local EPYTEST_DESELECT=()
+ case ${EPYTHON} in
+ pypy3)
+ EPYTEST_DESELECT+=(
+ "tests/test_main.py::test_small_samples[46597f8f896f11c5d7f432236344cc7e5645c2a39836eb6abdd2437c0422f0f4.py]"
+ )
+ ;;
+ python3.10)
+ EPYTEST_DESELECT+=(
+ # crashes with infinite recursion (?)
+ "tests/test_main.py::test_small_samples[1656dc52edd2385921104de7bb255ca369713f4b8c034ebeba5cf946058109bc.py]"
+ )
+ ;;
+ esac
+ if ! has_version "dev-python/ipython[${PYTHON_USEDEP}]"; then
+ EPYTEST_DESELECT+=(
+ tests/test_ipython.py
+ )
+ fi
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}
+
+pkg_postinst() {
+ optfeature "getting node's source code" dev-python/asttokens
+}
diff --git a/dev-python/executing/files/executing-2.0.1-additional-slow-tests.patch b/dev-python/executing/files/executing-2.0.1-additional-slow-tests.patch
new file mode 100644
index 000000000000..36346e7363fb
--- /dev/null
+++ b/dev-python/executing/files/executing-2.0.1-additional-slow-tests.patch
@@ -0,0 +1,38 @@
+https://bugs.gentoo.org/show_bug.cgi?id=909738
+https://github.com/alexmojaki/executing/pull/78
+
+From 9990d20a28d46e8a911c370a019f9231cad977f0 Mon Sep 17 00:00:00 2001
+From: matoro <matoro@users.noreply.github.com>
+Date: Sun, 5 Nov 2023 19:54:34 -0500
+Subject: [PATCH] Add many_calls tests to EXECUTING_SLOW_TESTS
+
+---
+ tests/test_main.py | 8 ++++++++
+ 1 file changed, 8 insertions(+)
+
+diff --git a/tests/test_main.py b/tests/test_main.py
+index 7e33247..bc015cd 100644
+--- a/tests/test_main.py
++++ b/tests/test_main.py
+@@ -279,6 +279,10 @@ def test_future_import(self):
+ print(1 / 2)
+ tester(4)
+
++ @pytest.mark.skipif(
++ not os.getenv("EXECUTING_SLOW_TESTS"),
++ reason="These tests are very slow, enable them explicitly",
++ )
+ def test_many_calls(self):
+ node = None
+ start = time.time()
+@@ -290,6 +294,10 @@ def test_many_calls(self):
+ self.assertIs(node, new_node)
+ self.assertLess(time.time() - start, 1)
+
++ @pytest.mark.skipif(
++ not os.getenv("EXECUTING_SLOW_TESTS"),
++ reason="These tests are very slow, enable them explicitly",
++ )
+ def test_many_source_for_filename_calls(self):
+ source = None
+ start = time.time()
diff --git a/dev-python/executing/metadata.xml b/dev-python/executing/metadata.xml
index 9117f7343c32..6e749ac9035b 100644
--- a/dev-python/executing/metadata.xml
+++ b/dev-python/executing/metadata.xml
@@ -1,5 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="project">
<email>python@gentoo.org</email>