summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/executing')
-rw-r--r--dev-python/executing/Manifest1
-rw-r--r--dev-python/executing/executing-0.9.1.ebuild42
2 files changed, 0 insertions, 43 deletions
diff --git a/dev-python/executing/Manifest b/dev-python/executing/Manifest
index cbd5786d768e..e19305e0f696 100644
--- a/dev-python/executing/Manifest
+++ b/dev-python/executing/Manifest
@@ -1,3 +1,2 @@
DIST executing-0.10.0.gh.tar.gz 507523 BLAKE2B 5ab17adb1d40b83b0cf294aba350faf124a810b4c95e408e9bd2ba80d918154cb41d8b4d4748cd7d897d47e085883a30f431dedd595b00506beb5038e084f473 SHA512 f1ee25679cd1f88f273ee68e8e926a6e98b749a50d063ea3aa73f35ac0d7ea65b13364269f01265f164dba1d775a742cd7cf3594558e06efb39fb1157b3b9f5c
-DIST executing-0.9.1.gh.tar.gz 506644 BLAKE2B 04d7012a348186c44c892d9f442b33042a9e01951c47b1d9a42ca22195dc7fa0b8f17ebf552ca65e9aa038942a6962941aeafee2d15bdcef834d413d5512c910 SHA512 98ba2f155324e05ae927d0a97ec6ff54bcfd8d38551dde872f12aedfefc2297003b50d17e6e32e89a909a9b1e70cec9d474db03d6a4f9fb1814ebcca045bb982
DIST executing-1.0.0.gh.tar.gz 507720 BLAKE2B 601ddbd4c7dacd6b72317e9f07d8b8566d14b1c805bb7a2768449d51bf75818945f3b61b67dd0402d1d6171bd74165107ef98e835910529d82b8858bd016ac6d SHA512 912cea61ddb2ef12034432d68fa7239daad3c6365dbcbed72f08121b9fdc07e614b5c2233c53f5f7ee3472fca4f690af3db0944a0ed2c83623de8d682cff0a61
diff --git a/dev-python/executing/executing-0.9.1.ebuild b/dev-python/executing/executing-0.9.1.ebuild
deleted file mode 100644
index 471d3466d941..000000000000
--- a/dev-python/executing/executing-0.9.1.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 2020-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit distutils-r1
-
-DESCRIPTION="Get information about what a Python frame is currently doing"
-HOMEPAGE="
- https://github.com/alexmojaki/executing/
- https://pypi.org/project/executing/
-"
-SRC_URI="
- https://github.com/alexmojaki/executing/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 hppa ~ia64 ppc ppc64 ~riscv ~s390 sparc x86"
-
-# asttokens is optional runtime dep
-BDEPEND="
- dev-python/setuptools_scm[${PYTHON_USEDEP}]
- test? (
- dev-python/asttokens[${PYTHON_USEDEP}]
- dev-python/littleutils[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
-
-python_test() {
- # this test explodes when collected by pytest
- "${EPYTHON}" tests/test_main.py || die "Tests failed with ${EPYTHON}"
- epytest tests/test_pytest.py
-}