summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/fakeredis')
-rw-r--r--dev-python/fakeredis/Manifest7
-rw-r--r--dev-python/fakeredis/fakeredis-1.5.1.ebuild44
-rw-r--r--dev-python/fakeredis/fakeredis-1.6.0.ebuild77
-rw-r--r--dev-python/fakeredis/fakeredis-1.6.1.ebuild76
-rw-r--r--dev-python/fakeredis/fakeredis-2.22.0.ebuild84
-rw-r--r--dev-python/fakeredis/fakeredis-2.23.0.ebuild89
-rw-r--r--dev-python/fakeredis/fakeredis-2.23.1.ebuild89
-rw-r--r--dev-python/fakeredis/fakeredis-2.23.2.ebuild89
-rw-r--r--dev-python/fakeredis/metadata.xml2
9 files changed, 356 insertions, 201 deletions
diff --git a/dev-python/fakeredis/Manifest b/dev-python/fakeredis/Manifest
index cf11b444080a..7e67f79a0354 100644
--- a/dev-python/fakeredis/Manifest
+++ b/dev-python/fakeredis/Manifest
@@ -1,3 +1,4 @@
-DIST fakeredis-1.5.1.gh.tar.gz 67064 BLAKE2B 6eac029b7de6fb2c9b56a60655b6a224cdcba25fa86662a0423044ab97248984c4c6cfbaacbe4bbb2e3fc6826693791f232c6c55d7f15995d0e5bd00370a9ba8 SHA512 74a238573f9f911e9a39885b52d8c908d51d5620e346b8927c161111ce193566c315999f71d3edb1cb1326970985fd73d533b5483afe0c98ad76798a3c15e242
-DIST fakeredis-1.6.0.gh.tar.gz 70034 BLAKE2B 3e9526bf8a7bdafe2b471f0a9d488f0d654e93666863513444521eefd0ca31dbba7e589431b5dee64b27dbf9c2bcc05c1517f659942aa4491cae42b1d11f45b9 SHA512 7a3aefc161b2396e748b284152e088fc31a49a859259888cf8dcfd3a72045e84079977b0e8f11b571ab00d6c00fcf82dc28a1a50fa75633cf17215553bbd019b
-DIST fakeredis-1.6.1.gh.tar.gz 70171 BLAKE2B f10ac8aaec73871153ac7557a40984e6752b7e3720c1890380bda4aad828003403b6207c5e4f4ace18814e6ad33355acca08ff53cc33cb43acb5d9955ea6e5fc SHA512 1a8718d277d15a887901ed29691af83a2aea57605edf8cf2dbdc00c397a62ea8c1ed21440adadcda431a8ae8f33c85b549c5458a958b1fb74996e54ab612cd13
+DIST fakeredis-2.22.0.tar.gz 130074 BLAKE2B 28ccc177c8f2d47515ff91834901b8fdf9559b83b1e7665101b5f17e57d65a3c820af6be21251257f35a7db858c22fac3395cfb550b724e020e96778ad380008 SHA512 a533f26c2a4289b1b4d398ee426f44c93f01a4aac0dc841854bf94674d7e0738fde38ea896280d4e83bf16041dba505db13e3fa3837a912dc872b1d36c05cc6e
+DIST fakeredis-2.23.0.tar.gz 133649 BLAKE2B 4dcfb0b52f18101311cd6513fa236ecc6100d12fdfceb9eef12e40ea4fc2a8148dd93e2ad9a68cf5347a3048a95136b7fcbedab2ea5348fa789462b9fee6f920 SHA512 8c3b4ad153232101203811d2891985474fe17a86693217cb58e694ded3c309d101a6bef52e1b544bbc489a0c355792bdbdbed220dca00d0f50afb2fb1c6438ce
+DIST fakeredis-2.23.1.tar.gz 132829 BLAKE2B 05bc696f22cd3280728cf96614ac68fa9243242934c2d25e09fc20a569295adea6b75efb890cc172b1a0c75b9d96e9a1b30c9c04a01bfca508609b3a6eaad5c5 SHA512 5b8d256460d5930896ee1d8b3259decfdee12d0699da852cf1d6ce2c00d70cb404840808c5385ebae8d4ba7accd744f7f969bee4fc73320f55fc34558dee1294
+DIST fakeredis-2.23.2.tar.gz 132956 BLAKE2B 48053663d6260d1153b57893795a97b8e72e21cad57907b006bb8be605cce56c474b1a6bb32d455f034da52bcf391d56139ed0c0bdff7f3c367cc0c365ebca40 SHA512 0994f7c7e955a8cc7b1046f62d37841ea592022f21c34cf1f7d3bb335ba88bda5abf08fa002b4b7c9f0b09a6837a38b1b49cec44a3185e16ab4d4711ad4f95d4
diff --git a/dev-python/fakeredis/fakeredis-1.5.1.ebuild b/dev-python/fakeredis/fakeredis-1.5.1.ebuild
deleted file mode 100644
index 2877b6f0adad..000000000000
--- a/dev-python/fakeredis/fakeredis-1.5.1.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 2020-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( pypy3 python3_{7..9} )
-inherit distutils-r1
-
-DESCRIPTION="Fake implementation of redis API for testing purposes"
-HOMEPAGE="
- https://github.com/jamesls/fakeredis/
- https://pypi.org/project/fakeredis/"
-SRC_URI="
- https://github.com/jamesls/fakeredis/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ~ppc ~ppc64 ~sparc x86"
-
-RDEPEND="
- dev-python/redis-py[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- dev-python/sortedcontainers[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/hypothesis[${PYTHON_USEDEP}]
- dev-python/pytest-mock[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- local excludes=(
- # tests for use with aioredis, not packaged in ::gentoo
- --ignore test/test_aioredis.py
- # tests requiring lupa (lua support)
- -k 'not test_eval and not test_lua and not test_script'
- )
-
- epytest "${excludes[@]}"
-}
diff --git a/dev-python/fakeredis/fakeredis-1.6.0.ebuild b/dev-python/fakeredis/fakeredis-1.6.0.ebuild
deleted file mode 100644
index 7540d1c5fdec..000000000000
--- a/dev-python/fakeredis/fakeredis-1.6.0.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 2020-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( pypy3 python3_{8..10} )
-inherit distutils-r1 optfeature
-
-DESCRIPTION="Fake implementation of redis API for testing purposes"
-HOMEPAGE="
- https://github.com/jamesls/fakeredis/
- https://pypi.org/project/fakeredis/"
-SRC_URI="
- https://github.com/jamesls/fakeredis/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86"
-
-RDEPEND="
- dev-python/redis-py[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- dev-python/sortedcontainers[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-db/redis
- dev-python/aioredis[${PYTHON_USEDEP}]
- dev-python/async_generator[${PYTHON_USEDEP}]
- dev-python/hypothesis[${PYTHON_USEDEP}]
- dev-python/pytest-mock[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-EPYTEST_DESELECT=(
- test/test_aioredis2.py::test_blocking_unblock
- test/test_aioredis2.py::test_pubsub
- "test/test_aioredis2.py::test_repr[fake]"
- test/test_hypothesis.py::TestJoint::test
- test/test_hypothesis.py::TestFuzz::test
-)
-
-python_test() {
- local args=(
- # tests requiring lupa (lua support)
- -k 'not test_eval and not test_lua and not test_script'
- )
- epytest "${args[@]}"
-}
-
-src_test() {
- local redis_pid="${T}"/redis.pid
- local redis_port=6379
- local redis_test_config="
- daemonize yes
- pidfile ${redis_pid}
- port ${redis_port}
- bind 127.0.0.1
- "
-
- elog "Spawning Redis"
- elog "NOTE: Port ${redis_port} must be free"
- "${EPREFIX}"/usr/sbin/redis-server - <<< "${redis_test_config}" || die
-
- # Run the tests
- distutils-r1_src_test
-
- # Clean up afterwards
- kill "$(<"${redis_pid}")" || die
-}
-
-pkg_postinst() {
- optfeature "Mock aioredis" dev-python/aioredis
-}
diff --git a/dev-python/fakeredis/fakeredis-1.6.1.ebuild b/dev-python/fakeredis/fakeredis-1.6.1.ebuild
deleted file mode 100644
index d1542e220ebf..000000000000
--- a/dev-python/fakeredis/fakeredis-1.6.1.ebuild
+++ /dev/null
@@ -1,76 +0,0 @@
-# Copyright 2020-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( pypy3 python3_{8..10} )
-inherit distutils-r1 optfeature
-
-DESCRIPTION="Fake implementation of redis API for testing purposes"
-HOMEPAGE="
- https://github.com/jamesls/fakeredis/
- https://pypi.org/project/fakeredis/"
-SRC_URI="
- https://github.com/jamesls/fakeredis/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86"
-
-RDEPEND="
- dev-python/redis-py[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- dev-python/sortedcontainers[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-db/redis
- dev-python/aioredis[${PYTHON_USEDEP}]
- dev-python/hypothesis[${PYTHON_USEDEP}]
- dev-python/pytest-mock[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-EPYTEST_DESELECT=(
- test/test_aioredis2.py::test_blocking_unblock
- test/test_aioredis2.py::test_pubsub
- "test/test_aioredis2.py::test_repr[fake]"
- test/test_hypothesis.py::TestJoint::test
- test/test_hypothesis.py::TestFuzz::test
-)
-
-python_test() {
- local args=(
- # tests requiring lupa (lua support)
- -k 'not test_eval and not test_lua and not test_script'
- )
- epytest "${args[@]}"
-}
-
-src_test() {
- local redis_pid="${T}"/redis.pid
- local redis_port=6379
- local redis_test_config="
- daemonize yes
- pidfile ${redis_pid}
- port ${redis_port}
- bind 127.0.0.1
- "
-
- einfo "Spawning Redis"
- einfo "NOTE: Port ${redis_port} must be free"
- "${EPREFIX}"/usr/sbin/redis-server - <<< "${redis_test_config}" || die
-
- # Run the tests
- distutils-r1_src_test
-
- # Clean up afterwards
- kill "$(<"${redis_pid}")" || die
-}
-
-pkg_postinst() {
- optfeature "Mock aioredis" dev-python/aioredis
-}
diff --git a/dev-python/fakeredis/fakeredis-2.22.0.ebuild b/dev-python/fakeredis/fakeredis-2.22.0.ebuild
new file mode 100644
index 000000000000..d0865eabf695
--- /dev/null
+++ b/dev-python/fakeredis/fakeredis-2.22.0.ebuild
@@ -0,0 +1,84 @@
+# Copyright 2020-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Fake implementation of redis API for testing purposes"
+HOMEPAGE="
+ https://github.com/cunla/fakeredis-py/
+ https://pypi.org/project/fakeredis/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ~arm arm64 ~ppc ~ppc64 ~riscv ~sparc x86"
+
+RDEPEND="
+ dev-python/packaging[${PYTHON_USEDEP}]
+ >=dev-python/redis-4.2[${PYTHON_USEDEP}]
+ <dev-python/sortedcontainers-3[${PYTHON_USEDEP}]
+ >=dev-python/sortedcontainers-2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-db/redis
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # also lupa
+ test/test_aioredis2.py::test_failed_script_error
+ # TODO
+ "test/test_fakeredis.py::test_set_get_nx[StrictRedis]"
+ "test/test_fakeredis.py::test_lpop_count[StrictRedis]"
+ "test/test_fakeredis.py::test_rpop_count[StrictRedis]"
+ "test/test_fakeredis.py::test_zadd_minus_zero[StrictRedis]"
+ "test/test_mixins/test_pubsub_commands.py::test_pubsub_channels[StrictRedis]"
+ test/test_mixins/test_set_commands.py::test_smismember_wrong_type
+ # new redis-server?
+ "test/test_mixins/test_pubsub_commands.py::test_pubsub_shardnumsub[StrictRedis]"
+ # json ext
+ test/test_json/test_json.py
+ test/test_json/test_json_arr_commands.py
+ )
+ local EPYTEST_IGNORE=(
+ # these tests fail a lot...
+ test/test_hypothesis.py
+ )
+ local args=(
+ # tests requiring lupa (lua support)
+ -k 'not test_eval and not test_lua and not test_script'
+ )
+ # Note: this package is not xdist-friendly
+ epytest "${args[@]}"
+}
+
+src_test() {
+ local redis_pid="${T}"/redis.pid
+ local redis_port=6379
+
+ einfo "Spawning Redis"
+ einfo "NOTE: Port ${redis_port} must be free"
+ "${EPREFIX}"/usr/sbin/redis-server - <<- EOF || die "Unable to start redis server"
+ daemonize yes
+ pidfile ${redis_pid}
+ port ${redis_port}
+ bind 127.0.0.1
+ EOF
+
+ # Run the tests
+ distutils-r1_src_test
+
+ # Clean up afterwards
+ kill "$(<"${redis_pid}")" || die
+}
diff --git a/dev-python/fakeredis/fakeredis-2.23.0.ebuild b/dev-python/fakeredis/fakeredis-2.23.0.ebuild
new file mode 100644
index 000000000000..fe8a86c29b94
--- /dev/null
+++ b/dev-python/fakeredis/fakeredis-2.23.0.ebuild
@@ -0,0 +1,89 @@
+# Copyright 2020-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Fake implementation of redis API for testing purposes"
+HOMEPAGE="
+ https://github.com/cunla/fakeredis-py/
+ https://pypi.org/project/fakeredis/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ dev-python/packaging[${PYTHON_USEDEP}]
+ >=dev-python/redis-4.2[${PYTHON_USEDEP}]
+ <dev-python/sortedcontainers-3[${PYTHON_USEDEP}]
+ >=dev-python/sortedcontainers-2[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ ' 3.10)
+"
+BDEPEND="
+ test? (
+ dev-db/redis
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # also lupa
+ test/test_aioredis2.py::test_failed_script_error
+ # TODO
+ "test/test_fakeredis.py::test_set_get_nx[StrictRedis]"
+ "test/test_fakeredis.py::test_lpop_count[StrictRedis]"
+ "test/test_fakeredis.py::test_rpop_count[StrictRedis]"
+ "test/test_fakeredis.py::test_zadd_minus_zero[StrictRedis]"
+ "test/test_mixins/test_pubsub_commands.py::test_pubsub_channels[StrictRedis]"
+ test/test_mixins/test_set_commands.py::test_smismember_wrong_type
+ # new redis-server?
+ "test/test_mixins/test_pubsub_commands.py::test_pubsub_shardnumsub[StrictRedis]"
+ # json ext
+ test/test_json/test_json.py
+ test/test_json/test_json_arr_commands.py
+ # tdigest ext?
+ 'test/test_mixins/test_server_commands.py::test_command[FakeStrictRedis]'
+ )
+ local EPYTEST_IGNORE=(
+ # these tests fail a lot...
+ test/test_hypothesis.py
+ )
+ local args=(
+ # tests requiring lupa (lua support)
+ -k 'not test_eval and not test_lua and not test_script'
+ )
+ # Note: this package is not xdist-friendly
+ epytest "${args[@]}"
+}
+
+src_test() {
+ local redis_pid="${T}"/redis.pid
+ local redis_port=6379
+
+ einfo "Spawning Redis"
+ einfo "NOTE: Port ${redis_port} must be free"
+ "${EPREFIX}"/usr/sbin/redis-server - <<- EOF || die "Unable to start redis server"
+ daemonize yes
+ pidfile ${redis_pid}
+ port ${redis_port}
+ bind 127.0.0.1
+ EOF
+
+ # Run the tests
+ distutils-r1_src_test
+
+ # Clean up afterwards
+ kill "$(<"${redis_pid}")" || die
+}
diff --git a/dev-python/fakeredis/fakeredis-2.23.1.ebuild b/dev-python/fakeredis/fakeredis-2.23.1.ebuild
new file mode 100644
index 000000000000..5bf1b6f5ea36
--- /dev/null
+++ b/dev-python/fakeredis/fakeredis-2.23.1.ebuild
@@ -0,0 +1,89 @@
+# Copyright 2020-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Fake implementation of redis API for testing purposes"
+HOMEPAGE="
+ https://github.com/cunla/fakeredis-py/
+ https://pypi.org/project/fakeredis/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ dev-python/packaging[${PYTHON_USEDEP}]
+ >=dev-python/redis-4.2[${PYTHON_USEDEP}]
+ <dev-python/sortedcontainers-3[${PYTHON_USEDEP}]
+ >=dev-python/sortedcontainers-2[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ ' 3.10)
+"
+BDEPEND="
+ test? (
+ dev-db/redis
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # also lupa
+ test/test_aioredis2.py::test_failed_script_error
+ # TODO
+ "test/test_fakeredis.py::test_set_get_nx[StrictRedis]"
+ "test/test_fakeredis.py::test_lpop_count[StrictRedis]"
+ "test/test_fakeredis.py::test_rpop_count[StrictRedis]"
+ "test/test_fakeredis.py::test_zadd_minus_zero[StrictRedis]"
+ "test/test_mixins/test_pubsub_commands.py::test_pubsub_channels[StrictRedis]"
+ test/test_mixins/test_set_commands.py::test_smismember_wrong_type
+ # new redis-server?
+ "test/test_mixins/test_pubsub_commands.py::test_pubsub_shardnumsub[StrictRedis]"
+ # json ext
+ test/test_json/test_json.py
+ test/test_json/test_json_arr_commands.py
+ # tdigest ext?
+ 'test/test_mixins/test_server_commands.py::test_command[FakeStrictRedis]'
+ )
+ local EPYTEST_IGNORE=(
+ # these tests fail a lot...
+ test/test_hypothesis.py
+ )
+ local args=(
+ # tests requiring lupa (lua support)
+ -k 'not test_eval and not test_lua and not test_script'
+ )
+ # Note: this package is not xdist-friendly
+ epytest "${args[@]}"
+}
+
+src_test() {
+ local redis_pid="${T}"/redis.pid
+ local redis_port=6379
+
+ einfo "Spawning Redis"
+ einfo "NOTE: Port ${redis_port} must be free"
+ "${EPREFIX}"/usr/sbin/redis-server - <<- EOF || die "Unable to start redis server"
+ daemonize yes
+ pidfile ${redis_pid}
+ port ${redis_port}
+ bind 127.0.0.1
+ EOF
+
+ # Run the tests
+ distutils-r1_src_test
+
+ # Clean up afterwards
+ kill "$(<"${redis_pid}")" || die
+}
diff --git a/dev-python/fakeredis/fakeredis-2.23.2.ebuild b/dev-python/fakeredis/fakeredis-2.23.2.ebuild
new file mode 100644
index 000000000000..5bf1b6f5ea36
--- /dev/null
+++ b/dev-python/fakeredis/fakeredis-2.23.2.ebuild
@@ -0,0 +1,89 @@
+# Copyright 2020-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Fake implementation of redis API for testing purposes"
+HOMEPAGE="
+ https://github.com/cunla/fakeredis-py/
+ https://pypi.org/project/fakeredis/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ dev-python/packaging[${PYTHON_USEDEP}]
+ >=dev-python/redis-4.2[${PYTHON_USEDEP}]
+ <dev-python/sortedcontainers-3[${PYTHON_USEDEP}]
+ >=dev-python/sortedcontainers-2[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ ' 3.10)
+"
+BDEPEND="
+ test? (
+ dev-db/redis
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # also lupa
+ test/test_aioredis2.py::test_failed_script_error
+ # TODO
+ "test/test_fakeredis.py::test_set_get_nx[StrictRedis]"
+ "test/test_fakeredis.py::test_lpop_count[StrictRedis]"
+ "test/test_fakeredis.py::test_rpop_count[StrictRedis]"
+ "test/test_fakeredis.py::test_zadd_minus_zero[StrictRedis]"
+ "test/test_mixins/test_pubsub_commands.py::test_pubsub_channels[StrictRedis]"
+ test/test_mixins/test_set_commands.py::test_smismember_wrong_type
+ # new redis-server?
+ "test/test_mixins/test_pubsub_commands.py::test_pubsub_shardnumsub[StrictRedis]"
+ # json ext
+ test/test_json/test_json.py
+ test/test_json/test_json_arr_commands.py
+ # tdigest ext?
+ 'test/test_mixins/test_server_commands.py::test_command[FakeStrictRedis]'
+ )
+ local EPYTEST_IGNORE=(
+ # these tests fail a lot...
+ test/test_hypothesis.py
+ )
+ local args=(
+ # tests requiring lupa (lua support)
+ -k 'not test_eval and not test_lua and not test_script'
+ )
+ # Note: this package is not xdist-friendly
+ epytest "${args[@]}"
+}
+
+src_test() {
+ local redis_pid="${T}"/redis.pid
+ local redis_port=6379
+
+ einfo "Spawning Redis"
+ einfo "NOTE: Port ${redis_port} must be free"
+ "${EPREFIX}"/usr/sbin/redis-server - <<- EOF || die "Unable to start redis server"
+ daemonize yes
+ pidfile ${redis_pid}
+ port ${redis_port}
+ bind 127.0.0.1
+ EOF
+
+ # Run the tests
+ distutils-r1_src_test
+
+ # Clean up afterwards
+ kill "$(<"${redis_pid}")" || die
+}
diff --git a/dev-python/fakeredis/metadata.xml b/dev-python/fakeredis/metadata.xml
index d6b0b74ee354..57d039bed0d9 100644
--- a/dev-python/fakeredis/metadata.xml
+++ b/dev-python/fakeredis/metadata.xml
@@ -7,6 +7,6 @@
<stabilize-allarches/>
<upstream>
<remote-id type="pypi">fakeredis</remote-id>
- <remote-id type="github">jamesls/fakeredis</remote-id>
+ <remote-id type="github">cunla/fakeredis-py</remote-id>
</upstream>
</pkgmetadata>