summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/falcon')
-rw-r--r--dev-python/falcon/Manifest4
-rw-r--r--dev-python/falcon/falcon-0.1.6.ebuild43
-rw-r--r--dev-python/falcon/falcon-0.1.7.ebuild44
-rw-r--r--dev-python/falcon/falcon-0.1.8.ebuild48
-rw-r--r--dev-python/falcon/falcon-0.1.9.ebuild48
-rw-r--r--dev-python/falcon/metadata.xml14
6 files changed, 201 insertions, 0 deletions
diff --git a/dev-python/falcon/Manifest b/dev-python/falcon/Manifest
new file mode 100644
index 000000000000..edffeee60fe2
--- /dev/null
+++ b/dev-python/falcon/Manifest
@@ -0,0 +1,4 @@
+DIST falcon-0.1.6.tar.gz 186870 SHA256 325503ae704420b91ffcb4c188d5ab15ae467b6168d7ccfacf905db1667022e3 SHA512 033b06d643dc910d62830d42a559a1fa1933b93c8f93b136c0ba89429cf3eadd912b5512f2add2ae904c3ff192046718a8d40a53d3a05506dfc2722cf5437668 WHIRLPOOL 1d93d1ffae86a167ab278fff3d6d653ea6b4df41723ea21f5149fa7316145ca9d8d6b8cde7ec1d018699cdbd86ebec87f682fd7a0f887f9e3f2926b18b6282ab
+DIST falcon-0.1.7.tar.gz 193151 SHA256 15c22f481b6152cb625d44ee852ec02cf775cb49f1fc9fa71cbc8d4fcccfbe7c SHA512 665a0bdd02c8e9a0806c863164fde33a6a10a1ac8c2ec9c3194da0ca41e411c19ec5b2a84cce521abb510588c23b4bb5fab25af58d5c17fbbf8e7c3304839b9a WHIRLPOOL 598f43cc59fd0d160e8a0fdb50385306c88a6becb5982110b4d9bd981e61768f1d33b46a51e44dfd0ec93114d156a56c9046e62daa044077246befa90009563d
+DIST falcon-0.1.8.tar.gz 202170 SHA256 e16c0e3062c4d6977e3ce892807d7e822c622f2743d9d97bd8be9babee29b63b SHA512 e0ec028c1d1dc3fba722bd91f9bb315523367313bef40238579a96ca49de37f4c63e53746bf6ab40add053320925378860e3571e32401151c00d4afcbad9b7ca WHIRLPOOL 1fa22d3167a12f992c5974864020ddcc89d6c9001d324e972b3e9fd8040ab8577cf955488c869fde662e0dfa98ed8c24e26f36b9b81ac9c282838aea6684e809
+DIST falcon-0.1.9.tar.gz 202209 SHA256 c8190ddf37dd8cf90f325a27185916e336e229292595f892043f55a502c04f94 SHA512 442a04c925f4af69bb0f1906c4123e68ef423e4040fbde82cecc200a44410665c0f97ad28e7f59e4139aae1209ba1df1dd445c5a44e6b975bed9416a97e681e8 WHIRLPOOL de1ff7b57a553efe9647b19c844107dc2a18dae0366c866ddf6d6035e40c1c532ad1bb81d03bc48af506996b4978c76392c98b4de5e8ba374dc3e6b4f334a27c
diff --git a/dev-python/falcon/falcon-0.1.6.ebuild b/dev-python/falcon/falcon-0.1.6.ebuild
new file mode 100644
index 000000000000..42c26a4b8d8b
--- /dev/null
+++ b/dev-python/falcon/falcon-0.1.6.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# Python 2.6 is supported, but depends on ordereddict, which has been in
+# improvise for months and is a minimal package. If needed
+# please let me know. PyPy also works
+PYTHON_COMPAT=( python{2_7,3_3} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="A supersonic micro-framework for building cloud APIs"
+HOMEPAGE="http://falconframework.org/ https://pypi.python.org/pypi/falcon"
+SRC_URI="https://github.com/racker/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+cython test"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]
+ cython? (
+ dev-python/cython[$(python_gen_usedep python{2_7,3_3})] )"
+
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/cython[$(python_gen_usedep python{2_7,3_3})]
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/testtools[${PYTHON_USEDEP}] )"
+
+python_test() {
+ nosetests || die "Testing failed with ${EPYTHON}"
+}
+
+src_prepare() {
+ if ! use cython; then
+ sed -i -e 's/if with_cython:/if False:/' setup.py \
+ || die 'sed failed.'
+ fi
+}
diff --git a/dev-python/falcon/falcon-0.1.7.ebuild b/dev-python/falcon/falcon-0.1.7.ebuild
new file mode 100644
index 000000000000..e3b2b3a64f16
--- /dev/null
+++ b/dev-python/falcon/falcon-0.1.7.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# Python 2.6 is supported, but depends on ordereddict, which has been in
+# improvise for months and is a minimal package. If needed
+# please let me know. PyPy also works
+PYTHON_COMPAT=( python{2_7,3_3} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="A supersonic micro-framework for building cloud APIs"
+HOMEPAGE="http://falconframework.org/ https://pypi.python.org/pypi/falcon"
+SRC_URI="https://github.com/racker/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+cython test"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]
+ dev-python/mimeparse[${PYTHON_USEDEP}]
+ cython? (
+ dev-python/cython[$(python_gen_usedep python{2_7,3_3})] )"
+
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/cython[$(python_gen_usedep python{2_7,3_3})]
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/testtools[${PYTHON_USEDEP}] )"
+
+python_test() {
+ nosetests || die "Testing failed with ${EPYTHON}"
+}
+
+src_prepare() {
+ if ! use cython; then
+ sed -i -e 's/if with_cython:/if False:/' setup.py \
+ || die 'sed failed.'
+ fi
+}
diff --git a/dev-python/falcon/falcon-0.1.8.ebuild b/dev-python/falcon/falcon-0.1.8.ebuild
new file mode 100644
index 000000000000..4cf1192409f3
--- /dev/null
+++ b/dev-python/falcon/falcon-0.1.8.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# Python 2.6 is supported, but depends on ordereddict, which has been in
+# improvise for months and is a minimal package. If needed
+# please let me know. PyPy also works
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="A supersonic micro-framework for building cloud APIs"
+HOMEPAGE="http://falconframework.org/ https://pypi.python.org/pypi/falcon"
+SRC_URI="https://github.com/racker/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+cython test"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]
+ dev-python/mimeparse[${PYTHON_USEDEP}]
+ cython? (
+ dev-python/cython[$(python_gen_usedep python{2_7,3_3})] )"
+
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/cython[$(python_gen_usedep python{2_7,3_3})]
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/testtools[${PYTHON_USEDEP}] )"
+
+python_test() {
+ nosetests || die "Testing failed with ${EPYTHON}"
+}
+
+src_prepare() {
+ if ! use cython; then
+ sed -i -e 's/if with_cython:/if False:/' setup.py \
+ || die 'sed failed.'
+ fi
+
+ # fix tests installation : potential file collision
+ sed -e 's@^where = tests@where = falcon/tests@g' -i setup.cfg || die
+ mv tests falcon/
+}
diff --git a/dev-python/falcon/falcon-0.1.9.ebuild b/dev-python/falcon/falcon-0.1.9.ebuild
new file mode 100644
index 000000000000..4cf1192409f3
--- /dev/null
+++ b/dev-python/falcon/falcon-0.1.9.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# Python 2.6 is supported, but depends on ordereddict, which has been in
+# improvise for months and is a minimal package. If needed
+# please let me know. PyPy also works
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="A supersonic micro-framework for building cloud APIs"
+HOMEPAGE="http://falconframework.org/ https://pypi.python.org/pypi/falcon"
+SRC_URI="https://github.com/racker/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+cython test"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]
+ dev-python/mimeparse[${PYTHON_USEDEP}]
+ cython? (
+ dev-python/cython[$(python_gen_usedep python{2_7,3_3})] )"
+
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/cython[$(python_gen_usedep python{2_7,3_3})]
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/testtools[${PYTHON_USEDEP}] )"
+
+python_test() {
+ nosetests || die "Testing failed with ${EPYTHON}"
+}
+
+src_prepare() {
+ if ! use cython; then
+ sed -i -e 's/if with_cython:/if False:/' setup.py \
+ || die 'sed failed.'
+ fi
+
+ # fix tests installation : potential file collision
+ sed -e 's@^where = tests@where = falcon/tests@g' -i setup.cfg || die
+ mv tests falcon/
+}
diff --git a/dev-python/falcon/metadata.xml b/dev-python/falcon/metadata.xml
new file mode 100644
index 000000000000..6e6c7a6301a4
--- /dev/null
+++ b/dev-python/falcon/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>rafaelmartins@gentoo.org</email>
+ <name>Rafael G. Martins</name>
+ </maintainer>
+ <use>
+ <flag name="cython">Build cython-based python modules</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">racker/falcon</remote-id>
+ </upstream>
+</pkgmetadata>