summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/fastjsonschema/fastjsonschema-2.14.5.ebuild')
-rw-r--r--dev-python/fastjsonschema/fastjsonschema-2.14.5.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/fastjsonschema/fastjsonschema-2.14.5.ebuild b/dev-python/fastjsonschema/fastjsonschema-2.14.5.ebuild
new file mode 100644
index 000000000000..cb687ee9c337
--- /dev/null
+++ b/dev-python/fastjsonschema/fastjsonschema-2.14.5.ebuild
@@ -0,0 +1,26 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+inherit distutils-r1
+
+MY_P=python-${P}
+DESCRIPTION="Fast JSON schema validator for Python"
+HOMEPAGE="https://github.com/horejsek/python-fastjsonschema/"
+SRC_URI="
+ https://github.com/horejsek/python-fastjsonschema/archive/v${PV}.tar.gz
+ -> ${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ distutils-r1_src_prepare
+ rm -r tests/benchmarks || die
+}