summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/filelock/filelock-3.1.0.ebuild')
-rw-r--r--dev-python/filelock/filelock-3.1.0.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/filelock/filelock-3.1.0.ebuild b/dev-python/filelock/filelock-3.1.0.ebuild
new file mode 100644
index 000000000000..ec08c0f21c42
--- /dev/null
+++ b/dev-python/filelock/filelock-3.1.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 2018-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+MY_P=py-filelock-${PV}
+DESCRIPTION="A platform independent file lock for Python"
+HOMEPAGE="https://github.com/benediktschmitt/py-filelock
+ https://pypi.org/project/filelock/"
+SRC_URI="https://github.com/benediktschmitt/py-filelock/archive/${PV}.tar.gz -> ${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Unlicense"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}