summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/filetype/filetype-1.0.7.ebuild')
-rw-r--r--dev-python/filetype/filetype-1.0.7.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/dev-python/filetype/filetype-1.0.7.ebuild b/dev-python/filetype/filetype-1.0.7.ebuild
new file mode 100644
index 000000000000..e0d6304e4217
--- /dev/null
+++ b/dev-python/filetype/filetype-1.0.7.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Small, dependency-free, fast Python package to infer binary file types checking"
+HOMEPAGE="https://github.com/h2non/filetype.py"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64"
+
+PATCHES=( "${FILESDIR}/${P}-examples.patch" )
+
+distutils_enable_tests unittest