summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/fitsio/fitsio-1.1.10.ebuild')
-rw-r--r--dev-python/fitsio/fitsio-1.1.10.ebuild46
1 files changed, 0 insertions, 46 deletions
diff --git a/dev-python/fitsio/fitsio-1.1.10.ebuild b/dev-python/fitsio/fitsio-1.1.10.ebuild
deleted file mode 100644
index 61d611cbdaa4..000000000000
--- a/dev-python/fitsio/fitsio-1.1.10.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_EXT=1
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} )
-
-inherit distutils-r1
-
-DESCRIPTION="Python library to read from and write to FITS files"
-HOMEPAGE="
- https://github.com/esheldon/fitsio/
- https://pypi.org/project/fitsio/
-"
-SRC_URI="
- https://github.com/esheldon/fitsio/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="GPL-2+"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-
-DEPEND="
- >=dev-python/numpy-1.11[${PYTHON_USEDEP}]
- sci-libs/cfitsio:0=
-"
-RDEPEND="
- ${DEPEND}
-"
-
-distutils_enable_tests pytest
-
-src_configure() {
- cat >> setup.cfg <<-EOF || die
- [build_ext]
- use_system_fitsio = True
- EOF
-}
-
-python_test() {
- cd "${BUILD_DIR}/install$(python_get_sitedir)" || die
- epytest
-}