summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/flake8')
-rw-r--r--dev-python/flake8/flake8-3.8.3-r1.ebuild (renamed from dev-python/flake8/flake8-3.8.3.ebuild)4
1 files changed, 2 insertions, 2 deletions
diff --git a/dev-python/flake8/flake8-3.8.3.ebuild b/dev-python/flake8/flake8-3.8.3-r1.ebuild
index ebb821972930..820cd24e17ee 100644
--- a/dev-python/flake8/flake8-3.8.3.ebuild
+++ b/dev-python/flake8/flake8-3.8.3-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( pypy3 python3_{6..8} )
+PYTHON_COMPAT=( pypy3 python3_{6..9} )
DISTUTILS_USE_SETUPTOOLS=rdepend
inherit distutils-r1
@@ -22,7 +22,7 @@ RDEPEND="
<dev-python/pyflakes-2.3.0[${PYTHON_USEDEP}]
>=dev-python/pycodestyle-2.6.0[${PYTHON_USEDEP}]
<dev-python/pycodestyle-2.7.0[${PYTHON_USEDEP}]
- dev-python/importlib_metadata[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/importlib_metadata[${PYTHON_USEDEP}]' pypy3 python3_{6,7})
"
PDEPEND="
>=dev-python/mccabe-0.6.0[${PYTHON_USEDEP}]