summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/flask-api/flask-api-1.0.ebuild')
-rw-r--r--dev-python/flask-api/flask-api-1.0.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/flask-api/flask-api-1.0.ebuild b/dev-python/flask-api/flask-api-1.0.ebuild
new file mode 100644
index 000000000000..a7ae0d383d16
--- /dev/null
+++ b/dev-python/flask-api/flask-api-1.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Browsable web APIs for Flask"
+HOMEPAGE="https://github.com/flask-api/flask-api"
+# pypi mirror don't have docs folder
+SRC_URI="${HOMEPAGE}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-python/flask[${PYTHON_USEDEP}]"
+
+DEPEND="
+ ${RDEPEND}
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )"
+
+python_install_all() {
+ distutils-r1_python_install_all
+ dodoc docs/about/* docs/api-guide/* docs/index.md
+}
+
+python_test() {
+ pytest || die
+}