summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/flask-bootstrap/flask-bootstrap-3.3.7.1.ebuild')
-rw-r--r--dev-python/flask-bootstrap/flask-bootstrap-3.3.7.1.ebuild59
1 files changed, 0 insertions, 59 deletions
diff --git a/dev-python/flask-bootstrap/flask-bootstrap-3.3.7.1.ebuild b/dev-python/flask-bootstrap/flask-bootstrap-3.3.7.1.ebuild
deleted file mode 100644
index 253b8637e985..000000000000
--- a/dev-python/flask-bootstrap/flask-bootstrap-3.3.7.1.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_6 )
-
-inherit distutils-r1
-
-DESCRIPTION="An extension that includes Bootstrap in your project, without boilerplate code"
-HOMEPAGE="https://pythonhosted.org/Flask-Bootstrap/"
-# PyPI tarballs don't include tests
-# https://github.com/mbr/flask-bootstrap/pull/134
-SRC_URI="https://github.com/mbr/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-python/dominate[${PYTHON_USEDEP}]
- dev-python/flask[${PYTHON_USEDEP}]
- dev-python/markupsafe[${PYTHON_USEDEP}]
- dev-python/visitor[${PYTHON_USEDEP}]
- dev-python/wtforms[${PYTHON_USEDEP}]
-"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- dev-python/flask-appconfig[${PYTHON_USEDEP}]
- dev-python/flask-debug[${PYTHON_USEDEP}]
- dev-python/flask-nav[${PYTHON_USEDEP}]
- dev-python/flask-wtf[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- ${RDEPEND}
- )
- doc? (
- dev-python/alabaster[${PYTHON_USEDEP}]
- dev-python/sphinx[${PYTHON_USEDEP}]
- )
-"
-
-python_prepare_all() {
- sed -i "s/, 'sphinx.ext.intersphinx'//" docs/conf.py || die
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- if use doc; then
- sphinx-build docs docs/_build/html || die
- HTML_DOCS=( docs/_build/html/. )
- fi
-}
-
-python_test() {
- # Skip one test which requires network access
- py.test -k "not test_versions_match" || die "Tests failed with ${EPYTHON}"
-}