summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/flask-htmlmin/flask-htmlmin-2.2.1-r1.ebuild')
-rw-r--r--dev-python/flask-htmlmin/flask-htmlmin-2.2.1-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/flask-htmlmin/flask-htmlmin-2.2.1-r1.ebuild b/dev-python/flask-htmlmin/flask-htmlmin-2.2.1-r1.ebuild
new file mode 100644
index 000000000000..3a9879bfb52d
--- /dev/null
+++ b/dev-python/flask-htmlmin/flask-htmlmin-2.2.1-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+MY_P="Flask-HTMLmin-${PV}"
+DESCRIPTION="Minimize your flask rendered html"
+HOMEPAGE="
+ https://github.com/hamidfzm/Flask-HTMLmin/
+ https://pypi.org/project/Flask-HTMLmin/
+"
+SRC_URI="
+ https://github.com/hamidfzm/Flask-HTMLmin/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ app-text/cssmin[${PYTHON_USEDEP}]
+ app-text/htmlmin[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest