summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/flask-login/flask-login-0.6.1.ebuild')
-rw-r--r--dev-python/flask-login/flask-login-0.6.1.ebuild42
1 files changed, 0 insertions, 42 deletions
diff --git a/dev-python/flask-login/flask-login-0.6.1.ebuild b/dev-python/flask-login/flask-login-0.6.1.ebuild
deleted file mode 100644
index c17cb52faeab..000000000000
--- a/dev-python/flask-login/flask-login-0.6.1.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit distutils-r1
-
-DESCRIPTION="Login session support for Flask"
-HOMEPAGE="
- https://github.com/maxcountryman/flask-login/
- https://pypi.org/project/Flask-Login/
-"
-SRC_URI="
- https://github.com/maxcountryman/flask-login/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ~ppc ~ppc64 ~riscv ~sparc x86"
-
-RDEPEND="
- >=dev-python/flask-1.0.4[${PYTHON_USEDEP}]
- >=dev-python/werkzeug-1.0.1[${PYTHON_USEDEP}]
-"
-DEPEND="
- test? (
- dev-python/asgiref[${PYTHON_USEDEP}]
- dev-python/blinker[${PYTHON_USEDEP}]
- dev-python/semantic_version[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_sphinx docs
-distutils_enable_tests pytest
-
-python_test() {
- epytest -p no:httpbin
-}