summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/flask-migrate')
-rw-r--r--dev-python/flask-migrate/Manifest2
-rw-r--r--dev-python/flask-migrate/flask-migrate-3.1.0.ebuild29
-rw-r--r--dev-python/flask-migrate/flask-migrate-4.0.7.ebuild46
-rw-r--r--dev-python/flask-migrate/metadata.xml1
4 files changed, 48 insertions, 30 deletions
diff --git a/dev-python/flask-migrate/Manifest b/dev-python/flask-migrate/Manifest
index 1f0ca6368dd0..a9ec36fee4e3 100644
--- a/dev-python/flask-migrate/Manifest
+++ b/dev-python/flask-migrate/Manifest
@@ -1 +1 @@
-DIST Flask-Migrate-3.1.0.gh.tar.gz 23752 BLAKE2B c668db793813658d1486dad662869b65fc5461bc7256e2ca42ca0d11da88fc3a40618946d03c7fd4f869d0eda21af2d9fe29f146dac4d364b4642c2cd26b6d96 SHA512 4e14fa04381c4217e78c3766c86891e88cd2ff4e2eb1ab3c3a51344cbbb192a083246e60cdb6cc4c1ef42bf8108420e3befa1b59c44fe0890e5202fd275b5805
+DIST Flask-Migrate-4.0.7.gh.tar.gz 27172 BLAKE2B 743eccd8705c57a5748676e3f824632d2a547291d9816f903311c7abbc62eb418bf422aed183b10d986a923a00337310b7ab03bce774f839c81520686a9b90f5 SHA512 51da745b60d43d24ee5b63e5ee7d354d12e53b7c62a9c639f322443df62113485a42a6fd21e50673742d6a35c1f175e15a2a0af8f20918b44bf34fc4c2da4c7c
diff --git a/dev-python/flask-migrate/flask-migrate-3.1.0.ebuild b/dev-python/flask-migrate/flask-migrate-3.1.0.ebuild
deleted file mode 100644
index a20023462880..000000000000
--- a/dev-python/flask-migrate/flask-migrate-3.1.0.ebuild
+++ /dev/null
@@ -1,29 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..10} )
-inherit distutils-r1
-
-MY_P="Flask-Migrate-${PV}"
-
-DESCRIPTION="SQLAlchemy database migrations for Flask applications using Alembic"
-HOMEPAGE="https://pypi.org/project/Flask-Migrate/"
-SRC_URI="
- https://github.com/miguelgrinberg/Flask-Migrate/archive/v${PV}.tar.gz
- -> ${MY_P}.gh.tar.gz
-"
-S="${WORKDIR}/${MY_P}"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 x86"
-
-RDEPEND="
- >=dev-python/alembic-0.7[${PYTHON_USEDEP}]
- >=dev-python/flask-0.9[${PYTHON_USEDEP}]
- >=dev-python/flask-sqlalchemy-1.0[${PYTHON_USEDEP}]
-"
-
-distutils_enable_tests --install unittest
diff --git a/dev-python/flask-migrate/flask-migrate-4.0.7.ebuild b/dev-python/flask-migrate/flask-migrate-4.0.7.ebuild
new file mode 100644
index 000000000000..484e8bfcdb5b
--- /dev/null
+++ b/dev-python/flask-migrate/flask-migrate-4.0.7.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+MY_P="Flask-Migrate-${PV}"
+DESCRIPTION="SQLAlchemy database migrations for Flask applications using Alembic"
+HOMEPAGE="
+ https://github.com/miguelgrinberg/Flask-Migrate/
+ https://pypi.org/project/Flask-Migrate/
+"
+SRC_URI="
+ https://github.com/miguelgrinberg/Flask-Migrate/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 arm64 x86"
+
+RDEPEND="
+ >=dev-python/alembic-1.9.0[${PYTHON_USEDEP}]
+ >=dev-python/flask-0.9[${PYTHON_USEDEP}]
+ >=dev-python/flask-sqlalchemy-1.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests unittest
+
+python_test() {
+ local -x PATH=${T}/bin:${PATH}
+
+ mkdir -p "${T}"/bin || die
+ cat > "${T}"/bin/flask <<-EOF || die
+ #!/bin/sh
+ exec ${EPYTHON} -m flask "\${@}"
+ EOF
+ chmod +x "${T}"/bin/flask || die
+
+ eunittest
+}
diff --git a/dev-python/flask-migrate/metadata.xml b/dev-python/flask-migrate/metadata.xml
index ecf1bcf6f89a..8c1ab3c38b70 100644
--- a/dev-python/flask-migrate/metadata.xml
+++ b/dev-python/flask-migrate/metadata.xml
@@ -7,6 +7,7 @@
</maintainer>
<stabilize-allarches/>
<upstream>
+ <remote-id type="github">miguelgrinberg/Flask-Migrate</remote-id>
<remote-id type="pypi">Flask-Migrate</remote-id>
</upstream>
</pkgmetadata>