summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/flask-nav')
-rw-r--r--dev-python/flask-nav/Manifest2
-rw-r--r--dev-python/flask-nav/files/flask-nav-0.6-py310.patch19
-rw-r--r--dev-python/flask-nav/flask-nav-0.6-r2.ebuild28
-rw-r--r--dev-python/flask-nav/flask-nav-0.6-r5.ebuild41
-rw-r--r--dev-python/flask-nav/metadata.xml2
5 files changed, 62 insertions, 30 deletions
diff --git a/dev-python/flask-nav/Manifest b/dev-python/flask-nav/Manifest
index 9b9e51c62b38..610ccc8eb327 100644
--- a/dev-python/flask-nav/Manifest
+++ b/dev-python/flask-nav/Manifest
@@ -1 +1 @@
-DIST flask-nav-0.6.tar.gz 12270 BLAKE2B eff90b6fc08629139012e2d920b4d464ed06954040a5e97636a7aa4d59d11654839460ef52477cfcec967bd774d942028a53675d682e850f08f6359c5cfbb54e SHA512 a7930687425a53fac9ad9a7cb65c2e2a759a0c9660189965bf37ea6e9925dd869074d37a283801631b3e6c3391f9f4167e0a36294104f72970e876b5a7a0930c
+DIST flask-nav-0.6.gh.tar.gz 12270 BLAKE2B eff90b6fc08629139012e2d920b4d464ed06954040a5e97636a7aa4d59d11654839460ef52477cfcec967bd774d942028a53675d682e850f08f6359c5cfbb54e SHA512 a7930687425a53fac9ad9a7cb65c2e2a759a0c9660189965bf37ea6e9925dd869074d37a283801631b3e6c3391f9f4167e0a36294104f72970e876b5a7a0930c
diff --git a/dev-python/flask-nav/files/flask-nav-0.6-py310.patch b/dev-python/flask-nav/files/flask-nav-0.6-py310.patch
new file mode 100644
index 000000000000..02a06a9c99d9
--- /dev/null
+++ b/dev-python/flask-nav/files/flask-nav-0.6-py310.patch
@@ -0,0 +1,19 @@
+diff --git a/flask_nav/__init__.py b/flask_nav/__init__.py
+index 7c25dfa..5826b9e 100644
+--- a/flask_nav/__init__.py
++++ b/flask_nav/__init__.py
+@@ -1,4 +1,4 @@
+-import collections
++import collections.abc
+ from importlib import import_module
+ import re
+
+@@ -46,7 +46,7 @@ class NavbarRenderingError(Exception):
+ pass
+
+
+-class ElementRegistry(collections.MutableMapping):
++class ElementRegistry(collections.abc.MutableMapping):
+ def __init__(self):
+ self._elems = {}
+
diff --git a/dev-python/flask-nav/flask-nav-0.6-r2.ebuild b/dev-python/flask-nav/flask-nav-0.6-r2.ebuild
deleted file mode 100644
index b4065c08eecc..000000000000
--- a/dev-python/flask-nav/flask-nav-0.6-r2.ebuild
+++ /dev/null
@@ -1,28 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( pypy3 python3_{7,8,9} )
-
-inherit distutils-r1
-
-DESCRIPTION="Easily create navigation for Flask applications."
-HOMEPAGE="https://pythonhosted.org/flask-nav/"
-# docs are missing from PyPI tarballs
-# https://github.com/mbr/flask-nav/pull/12
-SRC_URI="https://github.com/mbr/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND="
- dev-python/dominate[${PYTHON_USEDEP}]
- dev-python/flask[${PYTHON_USEDEP}]
- dev-python/markupsafe[${PYTHON_USEDEP}]
- dev-python/visitor[${PYTHON_USEDEP}]
-"
-
-distutils_enable_tests pytest
-distutils_enable_sphinx docs dev-python/alabaster
diff --git a/dev-python/flask-nav/flask-nav-0.6-r5.ebuild b/dev-python/flask-nav/flask-nav-0.6-r5.ebuild
new file mode 100644
index 000000000000..2ef2988a35b8
--- /dev/null
+++ b/dev-python/flask-nav/flask-nav-0.6-r5.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Easily create navigation for Flask applications"
+HOMEPAGE="
+ https://pythonhosted.org/flask-nav/
+ https://github.com/mbr/flask-nav/
+ https://pypi.org/project/flask-nav/
+"
+# docs are missing from PyPI tarballs
+# https://github.com/mbr/flask-nav/pull/12
+SRC_URI="
+ https://github.com/mbr/flask-nav/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/dominate[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/markupsafe[${PYTHON_USEDEP}]
+ dev-python/visitor[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs dev-python/alabaster
+
+PATCHES=(
+ # https://github.com/mbr/flask-nav/pull/27
+ "${FILESDIR}/${P}-py310.patch"
+)
diff --git a/dev-python/flask-nav/metadata.xml b/dev-python/flask-nav/metadata.xml
index efad6d365b0c..e59df1959d66 100644
--- a/dev-python/flask-nav/metadata.xml
+++ b/dev-python/flask-nav/metadata.xml
@@ -1,5 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
<email>sbraz@gentoo.org</email>