summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/flask-wtf/flask-wtf-0.12.ebuild')
-rw-r--r--dev-python/flask-wtf/flask-wtf-0.12.ebuild54
1 files changed, 0 insertions, 54 deletions
diff --git a/dev-python/flask-wtf/flask-wtf-0.12.ebuild b/dev-python/flask-wtf/flask-wtf-0.12.ebuild
deleted file mode 100644
index 2b954d8da5c4..000000000000
--- a/dev-python/flask-wtf/flask-wtf-0.12.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python{2_7,3_4,3_5} pypy )
-
-inherit distutils-r1
-
-MY_PN="Flask-WTF"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Simple integration of Flask and WTForms"
-HOMEPAGE="http://pythonhosted.org/Flask-WTF/ https://pypi.python.org/pypi/Flask-WTF"
-SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc test"
-
-RDEPEND="dev-python/flask[${PYTHON_USEDEP}]
- >=dev-python/wtforms-1.0.5[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- dev-python/nose[${PYTHON_USEDEP}]
- dev-python/flask-testing[${PYTHON_USEDEP}]
- dev-python/flask-uploads[${PYTHON_USEDEP}]
- dev-python/speaklater[${PYTHON_USEDEP}]
- dev-python/flask-babel[${PYTHON_USEDEP}] )
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}]
- $(python_gen_cond_dep 'dev-python/werkzeug[${PYTHON_USEDEP}]' python2_7 )
- )"
-
-S="${WORKDIR}/${MY_P}"
-
-python_prepare_all() {
- # tries to access things over the network
- rm tests/test_recaptcha.py || die
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_test() {
- nosetests || die "Tests failed under ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/_build/html/. )
- distutils-r1_python_install_all
-}