summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/flask-wtf/flask-wtf-1.0.0.ebuild')
-rw-r--r--dev-python/flask-wtf/flask-wtf-1.0.0.ebuild39
1 files changed, 0 insertions, 39 deletions
diff --git a/dev-python/flask-wtf/flask-wtf-1.0.0.ebuild b/dev-python/flask-wtf/flask-wtf-1.0.0.ebuild
deleted file mode 100644
index 7d81736c5d46..000000000000
--- a/dev-python/flask-wtf/flask-wtf-1.0.0.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} )
-inherit distutils-r1
-
-MY_PN="Flask-WTF"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Simple integration of Flask and WTForms"
-HOMEPAGE="https://pythonhosted.org/Flask-WTF/ https://pypi.org/project/Flask-WTF/"
-SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
-S="${WORKDIR}/${MY_P}"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 x86"
-
-RDEPEND="
- >=dev-python/Babel-1[${PYTHON_USEDEP}]
- dev-python/flask[${PYTHON_USEDEP}]
- dev-python/flask-babel[${PYTHON_USEDEP}]
- dev-python/itsdangerous[${PYTHON_USEDEP}]
- dev-python/jinja[${PYTHON_USEDEP}]
- dev-python/werkzeug[${PYTHON_USEDEP}]
- >=dev-python/wtforms-1.0.5[${PYTHON_USEDEP}]
-"
-
-distutils_enable_sphinx docs dev-python/pallets-sphinx-themes dev-python/sphinxcontrib-log_cabinet dev-python/sphinx-issues
-distutils_enable_tests pytest
-
-EPYTEST_DESELECT=(
- # tries to access things over the network
- tests/test_recaptcha.py
- # unpackaged Flask-Uploads
- tests/test_file.py
-)