summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/flatdict/flatdict-4.0.0.ebuild')
-rw-r--r--dev-python/flatdict/flatdict-4.0.0.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/flatdict/flatdict-4.0.0.ebuild b/dev-python/flatdict/flatdict-4.0.0.ebuild
new file mode 100644
index 000000000000..5a3a5555d40a
--- /dev/null
+++ b/dev-python/flatdict/flatdict-4.0.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python module for interacting with nested dicts"
+HOMEPAGE="
+ https://github.com/gmr/flatdict/
+ https://pypi.org/project/flatdict/
+"
+SRC_URI="
+ https://github.com/gmr/flatdict/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+distutils_enable_tests unittest