summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/flit_scm/flit_scm-1.7.0.ebuild')
-rw-r--r--dev-python/flit_scm/flit_scm-1.7.0.ebuild11
1 files changed, 5 insertions, 6 deletions
diff --git a/dev-python/flit_scm/flit_scm-1.7.0.ebuild b/dev-python/flit_scm/flit_scm-1.7.0.ebuild
index 6a3e2b913ae3..cfba15e67f03 100644
--- a/dev-python/flit_scm/flit_scm-1.7.0.ebuild
+++ b/dev-python/flit_scm/flit_scm-1.7.0.ebuild
@@ -1,10 +1,10 @@
-# Copyright 2022 Gentoo Authors
+# Copyright 2022-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DISTUTILS_USE_PEP517=standalone
-PYTHON_COMPAT=( pypy3 python3_{8..11} )
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
inherit distutils-r1
@@ -19,16 +19,15 @@ SRC_URI="
LICENSE="MIT"
SLOT="0"
-KEYWORDS="amd64 arm arm64 hppa ~ia64 ~m68k ppc ppc64 ~riscv ~s390 sparc x86"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
RDEPEND="
- >=dev-python/flit_core-3.5.0[${PYTHON_USEDEP}]
- >=dev-python/setuptools_scm-6.4.2[${PYTHON_USEDEP}]
+ >=dev-python/flit-core-3.5.0[${PYTHON_USEDEP}]
+ >=dev-python/setuptools-scm-6.4.2[${PYTHON_USEDEP}]
$(python_gen_cond_dep '
<dev-python/tomli-3[${PYTHON_USEDEP}]
>=dev-python/tomli-2[${PYTHON_USEDEP}]
' 3.8 3.9 3.10 )
-
"
src_prepare() {