summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/fqdn/fqdn-1.5.1.ebuild')
-rw-r--r--dev-python/fqdn/fqdn-1.5.1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/fqdn/fqdn-1.5.1.ebuild b/dev-python/fqdn/fqdn-1.5.1.ebuild
new file mode 100644
index 000000000000..91ac88a37d86
--- /dev/null
+++ b/dev-python/fqdn/fqdn-1.5.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 2018-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="RFC-compliant FQDN validation and manipulation for Python"
+HOMEPAGE="https://github.com/ypcrts/fqdn"
+SRC_URI="https://github.com/ypcrts/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/cached-property[${PYTHON_USEDEP}]
+ ' python3_7 pypy3)"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs