summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/furo/furo-2023.8.19.ebuild')
-rw-r--r--dev-python/furo/furo-2023.8.19.ebuild36
1 files changed, 0 insertions, 36 deletions
diff --git a/dev-python/furo/furo-2023.8.19.ebuild b/dev-python/furo/furo-2023.8.19.ebuild
deleted file mode 100644
index 1c42bf8413e1..000000000000
--- a/dev-python/furo/furo-2023.8.19.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 2021-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-# sphinx-theme-builder is completely unusable, as it requires pinning
-# to a very-specific nodejs version number, and ofc loves fetching
-# everything from the Internet
-
-DISTUTILS_USE_PEP517=standalone
-PYTHON_COMPAT=( pypy3 python3_{10..12} )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Clean customisable Sphinx documentation theme"
-HOMEPAGE="
- https://pypi.org/project/furo/
- https://github.com/pradyunsg/furo/
-"
-SRC_URI="$(pypi_wheel_url)"
-S=${WORKDIR}
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ppc ppc64 ~riscv ~s390 sparc x86"
-
-RDEPEND="
- dev-python/beautifulsoup4[${PYTHON_USEDEP}]
- dev-python/sphinx[${PYTHON_USEDEP}]
- dev-python/sphinx-basic-ng[${PYTHON_USEDEP}]
-"
-
-python_compile() {
- distutils_wheel_install "${BUILD_DIR}/install" \
- "${DISTDIR}/${P}-py3-none-any.whl"
-}