summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/furo/furo-2023.9.10.ebuild')
-rw-r--r--dev-python/furo/furo-2023.9.10.ebuild10
1 files changed, 8 insertions, 2 deletions
diff --git a/dev-python/furo/furo-2023.9.10.ebuild b/dev-python/furo/furo-2023.9.10.ebuild
index 1c42bf8413e1..d306ea1caab9 100644
--- a/dev-python/furo/furo-2023.9.10.ebuild
+++ b/dev-python/furo/furo-2023.9.10.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2021-2023 Gentoo Authors
+# Copyright 2021-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -22,7 +22,7 @@ S=${WORKDIR}
LICENSE="MIT"
SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ppc ppc64 ~riscv ~s390 sparc x86"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
RDEPEND="
dev-python/beautifulsoup4[${PYTHON_USEDEP}]
@@ -30,6 +30,12 @@ RDEPEND="
dev-python/sphinx-basic-ng[${PYTHON_USEDEP}]
"
+src_unpack() {
+ if [[ ${PKGBUMPING} == ${PVR} ]]; then
+ unzip "${DISTDIR}/${A}" || die
+ fi
+}
+
python_compile() {
distutils_wheel_install "${BUILD_DIR}/install" \
"${DISTDIR}/${P}-py3-none-any.whl"