summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/fuse-python/fuse-python-1.0.5.ebuild')
-rw-r--r--dev-python/fuse-python/fuse-python-1.0.5.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/fuse-python/fuse-python-1.0.5.ebuild b/dev-python/fuse-python/fuse-python-1.0.5.ebuild
new file mode 100644
index 000000000000..a00df7c82c9c
--- /dev/null
+++ b/dev-python/fuse-python/fuse-python-1.0.5.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+MY_P=python-fuse-${PV}
+DESCRIPTION="Python FUSE bindings"
+HOMEPAGE="https://github.com/libfuse/python-fuse"
+SRC_URI="
+ https://github.com/libfuse/python-fuse/archive/v${PV}.tar.gz
+ -> ${MY_P}.tar.gz
+"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="sys-fs/fuse:0="
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"