summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/gcs-oauth2-boto-plugin')
-rw-r--r--dev-python/gcs-oauth2-boto-plugin/Manifest1
-rw-r--r--dev-python/gcs-oauth2-boto-plugin/files/gcs-oauth2-boto-plugin-1.7-use-friendy-version-checks.patch13
-rw-r--r--dev-python/gcs-oauth2-boto-plugin/gcs-oauth2-boto-plugin-1.7.ebuild33
-rw-r--r--dev-python/gcs-oauth2-boto-plugin/gcs-oauth2-boto-plugin-1.8.ebuild32
4 files changed, 0 insertions, 79 deletions
diff --git a/dev-python/gcs-oauth2-boto-plugin/Manifest b/dev-python/gcs-oauth2-boto-plugin/Manifest
index a210483bc6da..a68ac5bf4642 100644
--- a/dev-python/gcs-oauth2-boto-plugin/Manifest
+++ b/dev-python/gcs-oauth2-boto-plugin/Manifest
@@ -1,3 +1,2 @@
-DIST gcs-oauth2-boto-plugin-1.7.tar.gz 13573 SHA256 a83dab83fb55c633bc5a80e6491e2aa00542914e7f550a8fecd1bb273d4b4dd4 SHA512 9972c7334d7710f3aa4f2aeb3b733a376fded6670b0fd950432af5b544b3e4e140bd8726112ab03bee79ee619660d1a71ac24f130be8de070671c2b8c400b8ae WHIRLPOOL 871aeb3db56d4e2727d5b42d3a0a97ca026d51c51abb7d439b0a372560713b53b9a2a5ad59e10bdd78bad591e37a08545bc2ce738d835583a3be319af503c7ca
DIST gcs-oauth2-boto-plugin-1.8.tar.gz 13248 SHA256 cb4f3c608c953c9f6eecbad0dd33c6a2dba283cf1cd332ceaac1a9ba8a17c64b SHA512 5504fc38d58ee68a78ee2b8e6c3757045494d000748382bc26888a65085cec08d2d137c63cb51afd1cef72d31b3f0cac5d40014548cca47c5322a67a7f1ef204 WHIRLPOOL 238ee67cdad11162abe614fad7d6eb6175a27fc132c790e17f4380373b8c8d48906e5ac361c4d3c34fbac85e851bdf6426c3660434bf809d4abca87f6cb995a9
DIST gcs-oauth2-boto-plugin-1.9.tar.gz 14625 SHA256 82e70621354a0291ff312d060fedf25f8016eb0af215d443562ac2b26f94b28d SHA512 439def0c7b78a103bd3041600e25eaede44c3aac8a161f12acd6dee98cd8404b03229df24cf4e7814d63600ca50793496a80893f1e32f8ed8ac4a2825dd07df8 WHIRLPOOL ba28ac45e909a2410f36c81ba7f5e83e9c71963b1fd4d69df7fe425d26f066ea8376cf935f6b732c57d98b7d2e770d68a2658953279f0985725970af9d206dd6
diff --git a/dev-python/gcs-oauth2-boto-plugin/files/gcs-oauth2-boto-plugin-1.7-use-friendy-version-checks.patch b/dev-python/gcs-oauth2-boto-plugin/files/gcs-oauth2-boto-plugin-1.7-use-friendy-version-checks.patch
deleted file mode 100644
index 665b1c4f01bb..000000000000
--- a/dev-python/gcs-oauth2-boto-plugin/files/gcs-oauth2-boto-plugin-1.7-use-friendy-version-checks.patch
+++ /dev/null
@@ -1,13 +0,0 @@
---- a/setup.py
-+++ b/setup.py
-@@ -36,9 +36,7 @@ requires = [
- 'python-gflags>=2.0',
- 'google-api-python-client>=1.1',
- 'pyOpenSSL>=0.13',
-- # Not using 1.02 because of:
-- # https://code.google.com/p/socksipy-branch/issues/detail?id=3
-- 'SocksiPy-branch==1.01',
-+ 'SocksiPy-branch>=1.01',
- 'retry_decorator>=1.0.0',
- ]
-
diff --git a/dev-python/gcs-oauth2-boto-plugin/gcs-oauth2-boto-plugin-1.7.ebuild b/dev-python/gcs-oauth2-boto-plugin/gcs-oauth2-boto-plugin-1.7.ebuild
deleted file mode 100644
index a849981785a7..000000000000
--- a/dev-python/gcs-oauth2-boto-plugin/gcs-oauth2-boto-plugin-1.7.ebuild
+++ /dev/null
@@ -1,33 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="5"
-PYTHON_COMPAT=( python2_7 )
-
-inherit distutils-r1
-
-DESCRIPTION="OAuth 2.0 plugin for Google Cloud Storage credentials in the Boto library"
-HOMEPAGE="https://pypi.python.org/pypi/gcs-oauth2-boto-plugin"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~x86"
-IUSE=""
-
-PATCHES=(
- "${FILESDIR}/${P}-use-friendy-version-checks.patch"
-)
-
-# Keep versions in sync with setup.py.
-RDEPEND="${PYTHON_DEPS}"
-DEPEND="${RDEPEND}
- >=dev-python/boto-2.29.1[${PYTHON_USEDEP}]
- >=dev-python/httplib2-0.8[${PYTHON_USEDEP}]
- >=dev-python/pyopenssl-0.13[${PYTHON_USEDEP}]
- >=dev-python/google-api-python-client-1.1[${PYTHON_USEDEP}]
- >=dev-python/python-gflags-2.0[${PYTHON_USEDEP}]
- >=dev-python/retry-decorator-1.0.0[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]
- >=dev-python/PySocks-1.01[${PYTHON_USEDEP}]"
diff --git a/dev-python/gcs-oauth2-boto-plugin/gcs-oauth2-boto-plugin-1.8.ebuild b/dev-python/gcs-oauth2-boto-plugin/gcs-oauth2-boto-plugin-1.8.ebuild
deleted file mode 100644
index 7f1871365199..000000000000
--- a/dev-python/gcs-oauth2-boto-plugin/gcs-oauth2-boto-plugin-1.8.ebuild
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="5"
-PYTHON_COMPAT=( python2_7 )
-
-inherit distutils-r1
-
-DESCRIPTION="OAuth 2.0 plugin for Google Cloud Storage credentials in the Boto library"
-HOMEPAGE="https://pypi.python.org/pypi/gcs-oauth2-boto-plugin"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~x86"
-IUSE=""
-
-PATCHES=(
- "${FILESDIR}/${P}-use-friendy-version-checks.patch"
-)
-
-# Keep versions in sync with setup.py.
-RDEPEND="${PYTHON_DEPS}"
-DEPEND="${RDEPEND}
- >=dev-python/boto-2.29.1[${PYTHON_USEDEP}]
- >=dev-python/httplib2-0.8[${PYTHON_USEDEP}]
- >=dev-python/pyopenssl-0.13[${PYTHON_USEDEP}]
- >=dev-python/google-api-python-client-1.1[${PYTHON_USEDEP}]
- >=dev-python/retry-decorator-1.0.0[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]
- >=dev-python/PySocks-1.01[${PYTHON_USEDEP}]"