summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/gevent-socketio/gevent-socketio-0.3.6.ebuild')
-rw-r--r--dev-python/gevent-socketio/gevent-socketio-0.3.6.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/gevent-socketio/gevent-socketio-0.3.6.ebuild b/dev-python/gevent-socketio/gevent-socketio-0.3.6.ebuild
new file mode 100644
index 000000000000..119c13b6c9a9
--- /dev/null
+++ b/dev-python/gevent-socketio/gevent-socketio-0.3.6.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="SocketIO server based on the Gevent pywsgi server"
+HOMEPAGE="http://pypi.python.org/pypi/gevent-socketio/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-python/gevent-websocket[${PYTHON_USEDEP}]
+ dev-python/gevent[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/versiontools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}] )"
+
+python_test() {
+ py.test -v || die
+}