summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/google-api-python-client/google-api-python-client-1.6.2.ebuild')
-rw-r--r--dev-python/google-api-python-client/google-api-python-client-1.6.2.ebuild45
1 files changed, 0 insertions, 45 deletions
diff --git a/dev-python/google-api-python-client/google-api-python-client-1.6.2.ebuild b/dev-python/google-api-python-client/google-api-python-client-1.6.2.ebuild
deleted file mode 100644
index dfb0efc4bc83..000000000000
--- a/dev-python/google-api-python-client/google-api-python-client-1.6.2.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python3_6 )
-
-inherit distutils-r1
-
-DESCRIPTION="Google API Client for Python"
-HOMEPAGE="https://github.com/google/google-api-python-client"
-SRC_URI="https://github.com/google/google-api-python-client/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- >=dev-python/httplib2-0.9.2[${PYTHON_USEDEP}]
- <dev-python/httplib2-1[${PYTHON_USEDEP}]
- >=dev-python/oauth2client-2[${PYTHON_USEDEP}]
- <dev-python/oauth2client-5[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]
- >=dev-python/uritemplate-3.0[${PYTHON_USEDEP}]
- <dev-python/uritemplate-4[${PYTHON_USEDEP}]
- >=dev-python/six-1.6.1[${PYTHON_USEDEP}]
- <dev-python/six-2[${PYTHON_USEDEP}]
- "
-DEPEND="${RDEPEND}
- test? (
- dev-python/google-auth-httplib2[${PYTHON_USEDEP}]
- dev-python/nose[${PYTHON_USEDEP}]
- dev-python/unittest2[${PYTHON_USEDEP}]
- )"
-
-python_prepare_all() {
- export SKIP_GOOGLEAPICLIENT_COMPAT_CHECK=true
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- nosetests --verbosity=3 || die
-}