summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/google-api-python-client/google-api-python-client-2.24.0.ebuild')
-rw-r--r--dev-python/google-api-python-client/google-api-python-client-2.24.0.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/google-api-python-client/google-api-python-client-2.24.0.ebuild b/dev-python/google-api-python-client/google-api-python-client-2.24.0.ebuild
new file mode 100644
index 000000000000..2bf8009bdc63
--- /dev/null
+++ b/dev-python/google-api-python-client/google-api-python-client-2.24.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..9} )
+inherit distutils-r1
+
+DESCRIPTION="Google API Client for Python"
+HOMEPAGE="https://github.com/googleapis/google-api-python-client"
+SRC_URI="https://github.com/googleapis/google-api-python-client/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/httplib2-0.15[${PYTHON_USEDEP}]
+ <dev-python/httplib2-1[${PYTHON_USEDEP}]
+ dev-python/google-api-core[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-1.35.0[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-httplib2-0.1.0[${PYTHON_USEDEP}]
+ >=dev-python/uritemplate-3.0.0[${PYTHON_USEDEP}]
+ <dev-python/uritemplate-4[${PYTHON_USEDEP}]
+ "
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/oauth2client[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/parameterized[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests --install pytest
+
+src_prepare() {
+ find tests -name '*.py' -exec \
+ sed -i -e 's:unittest2 as ::' {} + || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local deselect=(
+ # require Internet access (and credentials)
+ tests/test_discovery.py::DiscoveryErrors::test_credentials_and_credentials_file_mutually_exclusive
+ tests/test_discovery.py::DiscoveryFromDocument::test_api_endpoint_override_from_client_options_mapping_object
+ )
+
+ distutils_install_for_testing
+ epytest tests ${deselect[@]/#/--deselect }
+}