summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/google-apputils')
-rw-r--r--dev-python/google-apputils/google-apputils-0.4.0-r1.ebuild (renamed from dev-python/google-apputils/google-apputils-0.4.0.ebuild)6
-rw-r--r--dev-python/google-apputils/google-apputils-0.4.2-r1.ebuild (renamed from dev-python/google-apputils/google-apputils-0.4.2.ebuild)6
2 files changed, 12 insertions, 0 deletions
diff --git a/dev-python/google-apputils/google-apputils-0.4.0.ebuild b/dev-python/google-apputils/google-apputils-0.4.0-r1.ebuild
index a285ff34bc52..4ed6025a2842 100644
--- a/dev-python/google-apputils/google-apputils-0.4.0.ebuild
+++ b/dev-python/google-apputils/google-apputils-0.4.0-r1.ebuild
@@ -25,6 +25,12 @@ DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
dev-python/mox[${PYTHON_USEDEP}] )"
# version borders needed are already confluent with versions in the tree
+src_unpack() {
+ default
+ find ${P} -type d -exec chmod 0755 {} + || die
+ find ${P} -type f -exec chmod 0644 {} + || die
+}
+
python_prepare_all() {
# https://code.google.com/p/google-apputils-python/source/detail?r=12
# This version bordering is long out of date and wrong since end of March 2012!
diff --git a/dev-python/google-apputils/google-apputils-0.4.2.ebuild b/dev-python/google-apputils/google-apputils-0.4.2-r1.ebuild
index 055a248b970c..613b4dcc6735 100644
--- a/dev-python/google-apputils/google-apputils-0.4.2.ebuild
+++ b/dev-python/google-apputils/google-apputils-0.4.2-r1.ebuild
@@ -24,6 +24,12 @@ RDEPEND="
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
test? ( ${RDEPEND} dev-python/mox[${PYTHON_USEDEP}] )"
+src_unpack() {
+ default
+ find ${P} -type d -exec chmod 0755 {} + || die
+ find ${P} -type f -exec chmod 0644 {} + || die
+}
+
python_test() {
# These yield 2 fails which are in fact expected errors run from a shell script!
# They seemingly have no immediate mechanism to exit 0 in an expected fail style.