summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/google-auth')
-rw-r--r--dev-python/google-auth/Manifest5
-rw-r--r--dev-python/google-auth/google-auth-1.30.2.ebuild51
-rw-r--r--dev-python/google-auth/google-auth-1.33.0.ebuild51
-rw-r--r--dev-python/google-auth/google-auth-1.33.1.ebuild51
-rw-r--r--dev-python/google-auth/google-auth-2.29.0.ebuild (renamed from dev-python/google-auth/google-auth-1.32.1.ebuild)44
-rw-r--r--dev-python/google-auth/metadata.xml2
6 files changed, 28 insertions, 176 deletions
diff --git a/dev-python/google-auth/Manifest b/dev-python/google-auth/Manifest
index b75b3f7e50cc..08458e4f47fd 100644
--- a/dev-python/google-auth/Manifest
+++ b/dev-python/google-auth/Manifest
@@ -1,4 +1 @@
-DIST google-auth-1.30.2.tar.gz 169368 BLAKE2B c01191313b4bd7ffdc62fbca20aeadcb01fcb1f26e4c11504f88c2582b9a3dca10046edd5d2fe88c98980fb09e4d68da99bf0b8b5692abcf5271994515f91765 SHA512 f133ef403f8a3c92437055f2fd0e5f607199a0bfd9a76a44075a9be8ec16c4d4822d58d85fa52ade4c448e11cb6822f7e8da03ab72f3dddfb811c8d7a846f841
-DIST google-auth-1.32.1.tar.gz 171621 BLAKE2B e82f4666a38d3dbaa4aa4a4d5192afb711471432c0dcca44b1a1c52fa2171f1de0d7ffd8a7a6d5dc6dbc3a1dec16becabb26306a9ba3b3fd0998584dd1194cc6 SHA512 968c16c7fc5c8c589a94e24139c319ec7f2791b021d6240156d398d4795e6afee8e46591c4aa44457de6f98ca14e8edcb055fb3a02914b43ba5fab74a03d9fc6
-DIST google-auth-1.33.0.tar.gz 178385 BLAKE2B 7d98afcd3a1dfc12a2af48297188c10f9618483ebdeeb8f7e02fca59d6255210a64b4917507a4525a3d6838198035fd827a1276da2a1f06169e83d1ca75fb485 SHA512 19da14b89cac28cf824f258d3dc662cbf40f4227e840594148c7ea3a6640dc00f06653c1b29846a9569d938a0fa307aff1c8425c015ab46d276485210eeb1227
-DIST google-auth-1.33.1.tar.gz 178615 BLAKE2B 1600ca8861a7e75decfda5605414ff45d8f6d7ece40e0bb7a5892fe2289f1adc5bba313eab10c4d0e1f6e7a38634861e28518c2f02522ec924d6ed53805c4207 SHA512 c54356b21af5ddeda88023b886631050e8e4306ed444093ed6589d13d95af402f03928dc5b5f44f9b4c038128ed254aa14de6d852108f44949c42e2d05304062
+DIST google-auth-2.29.0.tar.gz 244326 BLAKE2B 36b0bd8f445e3c7c3e0a83d07cf5924401dec99cdd22a6042bf5b9ca1cc9b1e28d0029f8f1509bcb32a7c54abd7c453dd5077ad25886d265822cf1c880b1326f SHA512 0f6d7e9728479a5937d72321f5ae6cfa3592dd42bb518a5519fc0936b533472e872fe947470a1774f8e53a2dad3c65e001de3899b74b6373dd149c6944423473
diff --git a/dev-python/google-auth/google-auth-1.30.2.ebuild b/dev-python/google-auth/google-auth-1.30.2.ebuild
deleted file mode 100644
index a1b10b9fa2aa..000000000000
--- a/dev-python/google-auth/google-auth-1.30.2.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..9} )
-DISTUTILS_USE_SETUPTOOLS=rdepend
-
-inherit distutils-r1
-
-DESCRIPTION="Google Authentication Library"
-HOMEPAGE="
- https://github.com/googleapis/google-auth-library-python/
- https://pypi.org/project/google-auth/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 x86"
-
-RDEPEND="
- dev-python/namespace-google[${PYTHON_USEDEP}]
- >=dev-python/pyasn1-0.1.7[${PYTHON_USEDEP}]
- >=dev-python/pyasn1-modules-0.2.1[${PYTHON_USEDEP}]
- >=dev-python/rsa-3.1.4[${PYTHON_USEDEP}]
- >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
- >=dev-python/cachetools-2.0.0[${PYTHON_USEDEP}]
- "
-BDEPEND="
- test? (
- dev-python/cryptography[${PYTHON_USEDEP}]
- dev-python/flask[${PYTHON_USEDEP}]
- dev-python/freezegun[${PYTHON_USEDEP}]
- dev-python/grpcio[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/moto[${PYTHON_USEDEP}]
- dev-python/oauth2client[${PYTHON_USEDEP}]
- dev-python/pyopenssl[${PYTHON_USEDEP}]
- dev-python/pytest-localserver[${PYTHON_USEDEP}]
- dev-python/pyu2f[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- dev-python/responses[${PYTHON_USEDEP}]
- dev-python/urllib3[${PYTHON_USEDEP}]
- )"
-
-distutils_enable_tests pytest
-
-python_install_all() {
- distutils-r1_python_install_all
- find "${ED}" -name '*.pth' -delete || die
-}
diff --git a/dev-python/google-auth/google-auth-1.33.0.ebuild b/dev-python/google-auth/google-auth-1.33.0.ebuild
deleted file mode 100644
index 2bb9e016a997..000000000000
--- a/dev-python/google-auth/google-auth-1.33.0.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..9} )
-DISTUTILS_USE_SETUPTOOLS=rdepend
-
-inherit distutils-r1
-
-DESCRIPTION="Google Authentication Library"
-HOMEPAGE="
- https://github.com/googleapis/google-auth-library-python/
- https://pypi.org/project/google-auth/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~x86"
-
-RDEPEND="
- dev-python/namespace-google[${PYTHON_USEDEP}]
- >=dev-python/pyasn1-0.1.7[${PYTHON_USEDEP}]
- >=dev-python/pyasn1-modules-0.2.1[${PYTHON_USEDEP}]
- >=dev-python/rsa-3.1.4[${PYTHON_USEDEP}]
- >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
- >=dev-python/cachetools-2.0.0[${PYTHON_USEDEP}]
- "
-BDEPEND="
- test? (
- dev-python/cryptography[${PYTHON_USEDEP}]
- dev-python/flask[${PYTHON_USEDEP}]
- dev-python/freezegun[${PYTHON_USEDEP}]
- dev-python/grpcio[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/moto[${PYTHON_USEDEP}]
- dev-python/oauth2client[${PYTHON_USEDEP}]
- dev-python/pyopenssl[${PYTHON_USEDEP}]
- dev-python/pytest-localserver[${PYTHON_USEDEP}]
- dev-python/pyu2f[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- dev-python/responses[${PYTHON_USEDEP}]
- dev-python/urllib3[${PYTHON_USEDEP}]
- )"
-
-distutils_enable_tests pytest
-
-python_install_all() {
- distutils-r1_python_install_all
- find "${ED}" -name '*.pth' -delete || die
-}
diff --git a/dev-python/google-auth/google-auth-1.33.1.ebuild b/dev-python/google-auth/google-auth-1.33.1.ebuild
deleted file mode 100644
index 2bb9e016a997..000000000000
--- a/dev-python/google-auth/google-auth-1.33.1.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..9} )
-DISTUTILS_USE_SETUPTOOLS=rdepend
-
-inherit distutils-r1
-
-DESCRIPTION="Google Authentication Library"
-HOMEPAGE="
- https://github.com/googleapis/google-auth-library-python/
- https://pypi.org/project/google-auth/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~x86"
-
-RDEPEND="
- dev-python/namespace-google[${PYTHON_USEDEP}]
- >=dev-python/pyasn1-0.1.7[${PYTHON_USEDEP}]
- >=dev-python/pyasn1-modules-0.2.1[${PYTHON_USEDEP}]
- >=dev-python/rsa-3.1.4[${PYTHON_USEDEP}]
- >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
- >=dev-python/cachetools-2.0.0[${PYTHON_USEDEP}]
- "
-BDEPEND="
- test? (
- dev-python/cryptography[${PYTHON_USEDEP}]
- dev-python/flask[${PYTHON_USEDEP}]
- dev-python/freezegun[${PYTHON_USEDEP}]
- dev-python/grpcio[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/moto[${PYTHON_USEDEP}]
- dev-python/oauth2client[${PYTHON_USEDEP}]
- dev-python/pyopenssl[${PYTHON_USEDEP}]
- dev-python/pytest-localserver[${PYTHON_USEDEP}]
- dev-python/pyu2f[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- dev-python/responses[${PYTHON_USEDEP}]
- dev-python/urllib3[${PYTHON_USEDEP}]
- )"
-
-distutils_enable_tests pytest
-
-python_install_all() {
- distutils-r1_python_install_all
- find "${ED}" -name '*.pth' -delete || die
-}
diff --git a/dev-python/google-auth/google-auth-1.32.1.ebuild b/dev-python/google-auth/google-auth-2.29.0.ebuild
index 2bb9e016a997..3769f2621b5b 100644
--- a/dev-python/google-auth/google-auth-1.32.1.ebuild
+++ b/dev-python/google-auth/google-auth-2.29.0.ebuild
@@ -1,51 +1,59 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-PYTHON_COMPAT=( python3_{8..9} )
-DISTUTILS_USE_SETUPTOOLS=rdepend
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..12} )
-inherit distutils-r1
+inherit distutils-r1 pypi
DESCRIPTION="Google Authentication Library"
HOMEPAGE="
https://github.com/googleapis/google-auth-library-python/
- https://pypi.org/project/google-auth/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ https://pypi.org/project/google-auth/
+"
LICENSE="Apache-2.0"
SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+KEYWORDS="amd64 arm64 x86"
RDEPEND="
- dev-python/namespace-google[${PYTHON_USEDEP}]
+ <dev-python/cachetools-6.0.0[${PYTHON_USEDEP}]
>=dev-python/pyasn1-0.1.7[${PYTHON_USEDEP}]
>=dev-python/pyasn1-modules-0.2.1[${PYTHON_USEDEP}]
>=dev-python/rsa-3.1.4[${PYTHON_USEDEP}]
- >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
- >=dev-python/cachetools-2.0.0[${PYTHON_USEDEP}]
- "
+"
BDEPEND="
test? (
dev-python/cryptography[${PYTHON_USEDEP}]
dev-python/flask[${PYTHON_USEDEP}]
dev-python/freezegun[${PYTHON_USEDEP}]
- dev-python/grpcio[${PYTHON_USEDEP}]
dev-python/mock[${PYTHON_USEDEP}]
dev-python/moto[${PYTHON_USEDEP}]
- dev-python/oauth2client[${PYTHON_USEDEP}]
dev-python/pyopenssl[${PYTHON_USEDEP}]
dev-python/pytest-localserver[${PYTHON_USEDEP}]
dev-python/pyu2f[${PYTHON_USEDEP}]
dev-python/requests[${PYTHON_USEDEP}]
dev-python/responses[${PYTHON_USEDEP}]
- dev-python/urllib3[${PYTHON_USEDEP}]
- )"
+ )
+"
distutils_enable_tests pytest
-python_install_all() {
- distutils-r1_python_install_all
- find "${ED}" -name '*.pth' -delete || die
+python_test() {
+ local EPYTEST_IGNORE=(
+ # these are compatibility tests with oauth2client
+ # disable them to unblock removal of that package
+ tests/test__oauth2client.py
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}
+
+python_compile() {
+ distutils-r1_python_compile
+ find "${BUILD_DIR}" -name '*.pth' -delete || die
}
diff --git a/dev-python/google-auth/metadata.xml b/dev-python/google-auth/metadata.xml
index de47fac8c7a0..2e2db6e4c3fc 100644
--- a/dev-python/google-auth/metadata.xml
+++ b/dev-python/google-auth/metadata.xml
@@ -1,5 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
<email>zmedico@gentoo.org</email>