summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/google-auth')
-rw-r--r--dev-python/google-auth/Manifest1
-rw-r--r--dev-python/google-auth/google-auth-2.26.1.ebuild60
2 files changed, 0 insertions, 61 deletions
diff --git a/dev-python/google-auth/Manifest b/dev-python/google-auth/Manifest
index ba51724576a3..241a3398d73f 100644
--- a/dev-python/google-auth/Manifest
+++ b/dev-python/google-auth/Manifest
@@ -1,3 +1,2 @@
-DIST google-auth-2.26.1.tar.gz 238839 BLAKE2B 91f866d35a9a3c0faaa8305e0b4d28ce87c8c5cf7b1549d4b8cea6cda96efeda4909846fd50545774c8bb128a1b7b1b74bc79ffd9bd78c4ddf138d75829bedd8 SHA512 08593547cc447e10bc1a033f154f1f4e7a248250899ef2ea49aa818a2705d0df3aa01c4dc84b6f4eb1f51e08187c634d229c396d0f2615a987e7fcc2dec9010b
DIST google-auth-2.26.2.tar.gz 238968 BLAKE2B 58b8410130c68fbf24a40d57eae28107432e46a1676c1e32684c05cc1b1077dd5133a5891d89eedc9c9e4acacf9148deca5e650ad3860e6f23096f4dc0457aa3 SHA512 4a4ed658d0911f97e46f7ae2d59e5409facf639c6faeee506869b64d14a448fa7b83b4121bf1a48b515882e1fdececc7dbdd96562bb6b5cce7c7bfc86abe806a
DIST google-auth-2.27.0.tar.gz 239688 BLAKE2B 3fa3c3c3da41b6337140e0ae474ab5b3a2da5aad3d18be64959c90339e03279594af97033faf406c0e76a923686b89a8f55ce5f7dff3bf3ad4510aca85189240 SHA512 a352cfced15d3e312410d382170909024d00cc27c34c3ec166af36aacf37ea9ac76b5c8bafc6e1379e2ddf3e422c27ce996474338d4efd17c21c9e79f3756994
diff --git a/dev-python/google-auth/google-auth-2.26.1.ebuild b/dev-python/google-auth/google-auth-2.26.1.ebuild
deleted file mode 100644
index 300932aa0eee..000000000000
--- a/dev-python/google-auth/google-auth-2.26.1.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYPI_NO_NORMALIZE=1
-PYTHON_COMPAT=( python3_{10..11} )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Google Authentication Library"
-HOMEPAGE="
- https://github.com/googleapis/google-auth-library-python/
- https://pypi.org/project/google-auth/
-"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm arm64 x86"
-
-RDEPEND="
- <dev-python/cachetools-6.0.0[${PYTHON_USEDEP}]
- >=dev-python/pyasn1-0.1.7[${PYTHON_USEDEP}]
- >=dev-python/pyasn1-modules-0.2.1[${PYTHON_USEDEP}]
- >=dev-python/rsa-3.1.4[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/cryptography[${PYTHON_USEDEP}]
- dev-python/flask[${PYTHON_USEDEP}]
- dev-python/freezegun[${PYTHON_USEDEP}]
- dev-python/grpcio[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/moto[${PYTHON_USEDEP}]
- dev-python/pyopenssl[${PYTHON_USEDEP}]
- dev-python/pytest-localserver[${PYTHON_USEDEP}]
- dev-python/pyu2f[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- dev-python/responses[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- local EPYTEST_IGNORE=(
- # these are compatibility tests with oauth2client
- # disable them to unblock removal of that package
- tests/test__oauth2client.py
- )
-
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- epytest
-}
-
-python_compile() {
- distutils-r1_python_compile
- find "${BUILD_DIR}" -name '*.pth' -delete || die
-}