summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/google-reauth-python/google-reauth-python-0.1.1.ebuild')
-rw-r--r--dev-python/google-reauth-python/google-reauth-python-0.1.1.ebuild44
1 files changed, 0 insertions, 44 deletions
diff --git a/dev-python/google-reauth-python/google-reauth-python-0.1.1.ebuild b/dev-python/google-reauth-python/google-reauth-python-0.1.1.ebuild
deleted file mode 100644
index ae794b24b60f..000000000000
--- a/dev-python/google-reauth-python/google-reauth-python-0.1.1.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="7"
-
-PYTHON_COMPAT=( python3_{7..9} )
-
-inherit distutils-r1
-
-DESCRIPTION="Python based U2F host library"
-HOMEPAGE="https://github.com/google/google-reauth-python"
-SRC_URI="https://github.com/google/google-reauth-python/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- >=dev-python/oauth2client-2.0.0[${PYTHON_USEDEP}]
- dev-python/pyu2f[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
-"
-DEPEND="
- ${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- )
-"
-
-DOCS=( CHANGELOG.rst CONTRIBUTING.rst README.rst )
-
-distutils_enable_tests pytest
-
-python_prepare_all() {
- sed -e "s:'some_origin'.encode('ascii'):'some_origin':" \
- -e "s:SignResponse('key_handle', 'resp',:SignResponse('key_handle'.encode(), 'resp'.encode(),:" \
- -i tests/test_reauth.py || die
-
- distutils-r1_python_prepare_all
-}