summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/gpep517')
-rw-r--r--dev-python/gpep517/Manifest1
-rw-r--r--dev-python/gpep517/gpep517-9.ebuild41
2 files changed, 0 insertions, 42 deletions
diff --git a/dev-python/gpep517/Manifest b/dev-python/gpep517/Manifest
index 0e4492f1ba94..9692c0baef5a 100644
--- a/dev-python/gpep517/Manifest
+++ b/dev-python/gpep517/Manifest
@@ -1,2 +1 @@
DIST gpep517-11.gh.tar.gz 15344 BLAKE2B 14f3f4b284eb4f7de8a78a9215cf2ec7fc84cb4028d83555b595a245d5ff2eb78be5049b30ccca944c35c40db0cc61e1afeaa68b25a0d6f3608363af75059762 SHA512 5ce840841d99c20d62b5b6c8dcb6ec353e40c75537aa99e44fa7dc13bff37444cd66d4cbc97eb1b107b6df85edfda853343d5e8ef1865d0d5ccd293c1496b5c0
-DIST gpep517-9.gh.tar.gz 15227 BLAKE2B b3c2b3e4452a7e27725eea0a6a0b1b362e1ea6bbdae44d99a2992c9edac80a4fdbf2ed75a231004534039c6d6f6db54d9fdbdc7c2c7044bb85cbc3f88484be41 SHA512 94cd1ddb1de7844504906b056ec5eb9d0e80da4f6bde6b561075c754a78a97e6db6025a793592c9498fad54ebab48c5497b29268c40d6992f5ef793a698b9da1
diff --git a/dev-python/gpep517/gpep517-9.ebuild b/dev-python/gpep517/gpep517-9.ebuild
deleted file mode 100644
index c92961cc5e62..000000000000
--- a/dev-python/gpep517/gpep517-9.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-# please keep this ebuild at EAPI 7 -- sys-apps/portage dep
-EAPI=7
-
-DISTUTILS_USE_PEP517=no
-PYTHON_COMPAT=( pypy3 python3_{8..11} )
-
-inherit distutils-r1
-
-DESCRIPTION="A backend script to aid installing Python packages in Gentoo"
-HOMEPAGE="
- https://pypi.org/project/gpep517/
- https://github.com/projg2/gpep517/
-"
-SRC_URI="
- https://github.com/projg2/gpep517/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-
-RDEPEND="
- >=dev-python/installer-0.5.0[${PYTHON_USEDEP}]
- >=dev-python/tomli-1.2.3[${PYTHON_USEDEP}]
-"
-
-distutils_enable_tests pytest
-
-python_install() {
- python_domodule gpep517
- python_newscript - gpep517 <<-EOF
- #!${EPREFIX}/usr/bin/python
- import sys
- from gpep517.__main__ import main
- sys.exit(main())
- EOF
-}