summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/graphviz/graphviz-0.7.1.ebuild')
-rw-r--r--dev-python/graphviz/graphviz-0.7.1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/graphviz/graphviz-0.7.1.ebuild b/dev-python/graphviz/graphviz-0.7.1.ebuild
new file mode 100644
index 000000000000..a2327f77b8aa
--- /dev/null
+++ b/dev-python/graphviz/graphviz-0.7.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_5 python3_6 )
+
+inherit distutils-r1
+
+DESCRIPTION="Simple Python interface for Graphviz"
+HOMEPAGE="https://graphviz.readthedocs.io/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+SLOT="0"
+IUSE="test"
+
+RDEPEND="media-gfx/graphviz"
+DEPEND="
+ app-arch/unzip
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND}
+ >=dev-python/pytest-3.1[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ py.test -v || die
+}