summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/graphviz')
-rw-r--r--dev-python/graphviz/Manifest3
-rw-r--r--dev-python/graphviz/graphviz-0.16.ebuild34
-rw-r--r--dev-python/graphviz/graphviz-0.17.ebuild33
-rw-r--r--dev-python/graphviz/graphviz-0.20.3.ebuild54
-rw-r--r--dev-python/graphviz/metadata.xml3
5 files changed, 57 insertions, 70 deletions
diff --git a/dev-python/graphviz/Manifest b/dev-python/graphviz/Manifest
index 06ca7da83f3b..d81cb9cd0b07 100644
--- a/dev-python/graphviz/Manifest
+++ b/dev-python/graphviz/Manifest
@@ -1,2 +1 @@
-DIST graphviz-0.16.zip 193031 BLAKE2B abedbe170eaf9d3ad83f91b5ad13aa9fbda8669ac19ebbd1087aeab3f9401b0b8e6557313e04d791451ee501c75bc2843d89d1a0f789a219b0db771467b4b8bb SHA512 7896901decf712657d4cb16fad58eab8492e1476e60a32b1a7fa37ede2e9c47ed31c00b7dedcaafdee291e2cfe6b2e2affa352282665782829fd3fb2f30bdf92
-DIST graphviz-0.17.zip 193647 BLAKE2B f2f5ad728157d60c48964d2cfdc76559310af6099a9eae16279b0f9e8a41c08d02d5f255be62222c1f0808750a26e67822b5fbb930f7ada5c6a614c3607494cd SHA512 02f5ef21f9e3bf3b609f43fe0d9cb51632ea43c878055746af62fda4dd55883f6ad58f69faecb6aba552100cc835901309c8c2ec833cd74c617619fce2d49600
+DIST graphviz-0.20.3.gh.tar.gz 190499 BLAKE2B 841362c30feb7683371e557706fdcad27c52f6279bbb252a83f61127649e81f162ea80e8b2685dbf1c4f9e6f530409f7f5363ac573edf7d9942126be8ad85842 SHA512 e920093e499a539b1c8b5b250f2feeb0829caffd7ad27ae762cb7d4f8762e20bc4c9c72ac2a8d0efbbc81a3eef3289f5f66eed6c6db45353c9d802594449f6ae
diff --git a/dev-python/graphviz/graphviz-0.16.ebuild b/dev-python/graphviz/graphviz-0.16.ebuild
deleted file mode 100644
index 81c5fbf1cbdf..000000000000
--- a/dev-python/graphviz/graphviz-0.16.ebuild
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit distutils-r1
-
-DESCRIPTION="Simple Python interface for Graphviz"
-HOMEPAGE="https://graphviz.readthedocs.io/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
-
-LICENSE="MIT"
-KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
-SLOT="0"
-
-RDEPEND="media-gfx/graphviz"
-BDEPEND="
- app-arch/unzip
- test? ( ${RDEPEND}
- >=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
- >=dev-python/pytest-mock-1.8[${PYTHON_USEDEP}]
- media-gfx/graphviz[gts,pdf]
- )
-"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- sed -e 's:--cov --cov-report=term --cov-report=html::' \
- -i setup.cfg || die
- distutils-r1_src_prepare
-}
diff --git a/dev-python/graphviz/graphviz-0.17.ebuild b/dev-python/graphviz/graphviz-0.17.ebuild
deleted file mode 100644
index befd64b4a916..000000000000
--- a/dev-python/graphviz/graphviz-0.17.ebuild
+++ /dev/null
@@ -1,33 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} )
-inherit distutils-r1
-
-DESCRIPTION="Simple Python interface for Graphviz"
-HOMEPAGE="https://graphviz.readthedocs.io/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
-
-LICENSE="MIT"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-SLOT="0"
-
-RDEPEND="media-gfx/graphviz"
-BDEPEND="
- app-arch/unzip
- test? (
- >=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
- >=dev-python/pytest-mock-1.8[${PYTHON_USEDEP}]
- media-gfx/graphviz[gts,pdf]
- )
-"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- sed -e 's:--cov --cov-report=term --cov-report=html::' \
- -i setup.cfg || die
- distutils-r1_src_prepare
-}
diff --git a/dev-python/graphviz/graphviz-0.20.3.ebuild b/dev-python/graphviz/graphviz-0.20.3.ebuild
new file mode 100644
index 000000000000..0c14673b20f1
--- /dev/null
+++ b/dev-python/graphviz/graphviz-0.20.3.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Simple Python interface for Graphviz"
+HOMEPAGE="
+ https://graphviz.readthedocs.io/
+ https://github.com/xflr6/graphviz/
+ https://pypi.org/project/graphviz/
+"
+SRC_URI="
+ https://github.com/xflr6/graphviz/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 ~riscv x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ media-gfx/graphviz
+"
+BDEPEND="
+ test? (
+ >=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-mock-1.8[${PYTHON_USEDEP}]
+ media-gfx/graphviz[gts,pdf]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -e 's:license_file:license_files:' \
+ -e 's:--cov --cov-report=term --cov-report=html::' \
+ -i setup.cfg || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local EPYTEST_IGNORE=(
+ # workaround https://github.com/pytest-dev/pytest/issues/12123
+ tests/backend/conftest.py
+ tests/conftest.py
+ )
+ epytest -p pytest_mock
+}
diff --git a/dev-python/graphviz/metadata.xml b/dev-python/graphviz/metadata.xml
index 411953de1313..a16a2d40fe06 100644
--- a/dev-python/graphviz/metadata.xml
+++ b/dev-python/graphviz/metadata.xml
@@ -1,5 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="project">
<email>python@gentoo.org</email>
@@ -13,5 +13,6 @@
<stabilize-allarches/>
<upstream>
<remote-id type="pypi">graphviz</remote-id>
+ <remote-id type="github">xflr6/graphviz</remote-id>
</upstream>
</pkgmetadata>