summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/griffe')
-rw-r--r--dev-python/griffe/Manifest1
-rw-r--r--dev-python/griffe/griffe-0.33.0.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/griffe/Manifest b/dev-python/griffe/Manifest
index e6f2e527cd93..e6ce4af11656 100644
--- a/dev-python/griffe/Manifest
+++ b/dev-python/griffe/Manifest
@@ -1 +1,2 @@
DIST griffe-0.32.3.gh.tar.gz 176939 BLAKE2B 291878054cac7d2fd4daea922c0439dd839611af7c425e838414d01fab76b4799adeff5fe14ed078172a38180d49c93ea4238b3256f1668d4daa2c74f68007a8 SHA512 cf163c9f873eff04d5c932a197a4768c14813d8e4aa5e0c5223544f7eb8c34b0b5eb3838c669a034c71b25c909b2857d88ddf40431b5604f86613c6b3c871aa5
+DIST griffe-0.33.0.gh.tar.gz 178095 BLAKE2B 003b1eee693742e15635e685042540d94d9fe789c7462b3a43caff222e64216a25b5477022a18d60e867ae4fe7d909d3d8a68b1607655bdb99430c9c45e83bf6 SHA512 dd40dfc5bfa7bc63673f96b6d8e32b104fcf64959dd08ea60847a6ae351a3cb67848bc515e796802c3c0c1cc0958f9853779bbb24bb5be668ccf14d540b084aa
diff --git a/dev-python/griffe/griffe-0.33.0.ebuild b/dev-python/griffe/griffe-0.33.0.ebuild
new file mode 100644
index 000000000000..c8d57610c9ff
--- /dev/null
+++ b/dev-python/griffe/griffe-0.33.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=pdm-backend
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Signature generator for Python programs"
+HOMEPAGE="
+ https://mkdocstrings.github.io/griffe/
+ https://github.com/mkdocstrings/griffe/
+ https://pypi.org/project/griffe/
+"
+# Tests need files absent from the PyPI tarballs
+SRC_URI="
+ https://github.com/mkdocstrings/griffe/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv"
+
+RDEPEND="
+ >=dev-python/colorama-0.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/jsonschema-4.17.3[${PYTHON_USEDEP}]
+ >=dev-python/pytest-xdist-2.4[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+export PDM_BUILD_SCM_VERSION=${PV}
+
+EPYTEST_DESELECT=(
+ # fragile to installed packages
+ # (failed on PySide2 for me)
+ tests/test_stdlib.py::test_fuzzing_on_stdlib
+)