summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/gssapi')
-rw-r--r--dev-python/gssapi/Manifest1
-rw-r--r--dev-python/gssapi/gssapi-1.8.0.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/gssapi/Manifest b/dev-python/gssapi/Manifest
index 623051020860..5c6f69aa5921 100644
--- a/dev-python/gssapi/Manifest
+++ b/dev-python/gssapi/Manifest
@@ -1 +1,2 @@
DIST gssapi-1.7.3.gh.tar.gz 3830322 BLAKE2B ea3d633b9b88ab5105b5ba67dfd0ec138ac76e121be2ee82c43ca4f2a229c4592f5d417f5b9b0c8d2ce894bdcc35025361431280c4dc8a17782d1ea920390805 SHA512 8bb6346ef9dc5cb380bbe5e51931aa3470149d33a3eeef68a758ce0b2ef06785bdca9cb7ae809a8329ab2a05ac802ac3100f9d8e3d7d3034b4bbce1bc87b4268
+DIST gssapi-1.8.0.gh.tar.gz 113341 BLAKE2B c9e7890e7a318b055515b991b1d39a5677e591819d010edb45f8ce58541aa03e918d177fab506c37e8f1c54ee54fb145b5aa89bf69e353c1fd6c95a6d880e6d3 SHA512 47b3f295134d18240e8b53cacaf060661d024cc10846155318047640e508ffd05daa09240576ccb898ca71df254d0f030562e285d58d9e6c3258f10bb642d6de
diff --git a/dev-python/gssapi/gssapi-1.8.0.ebuild b/dev-python/gssapi/gssapi-1.8.0.ebuild
new file mode 100644
index 000000000000..1c7d320855eb
--- /dev/null
+++ b/dev-python/gssapi/gssapi-1.8.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Low and high level wrappers around the GSSAPI C libraries"
+HOMEPAGE="https://github.com/pythongssapi/python-gssapi https://pypi.org/project/gssapi/"
+SRC_URI="
+ https://github.com/pythongssapi/python-gssapi/releases/download/v${PV}/python-${P}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S="${WORKDIR}"/python-${P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/decorator[${PYTHON_USEDEP}]
+ virtual/krb5
+"
+
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+ virtual/krb5
+ test? (
+ dev-python/k5test[${PYTHON_USEDEP}]
+ dev-python/parameterized[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ cd "${T}" || die
+ epytest --pyargs gssapi
+}