summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/gst-python/files')
-rw-r--r--dev-python/gst-python/files/gst-python-0.10.9-lazy.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/gst-python/files/gst-python-0.10.9-lazy.patch b/dev-python/gst-python/files/gst-python-0.10.9-lazy.patch
new file mode 100644
index 000000000000..880d5508b2ee
--- /dev/null
+++ b/dev-python/gst-python/files/gst-python-0.10.9-lazy.patch
@@ -0,0 +1,21 @@
+diff -ur gst-python-0.10.9.orig/configure.ac gst-python-0.10.9/configure.ac
+--- gst-python-0.10.9.orig/configure.ac 2007-11-28 11:33:05.000000000 +0200
++++ gst-python-0.10.9/configure.ac 2007-11-28 18:09:48.000000000 +0200
+@@ -363,6 +363,17 @@
+
+ AG_GST_VALGRIND_CHECK
+
++AC_MSG_CHECKING([whether $LD accepts -z,lazy])
++case `$LD -z,lazy -v 2>&1 </dev/null` in
++*GNU* | *'with BFD'*)
++ LDFLAGS="$LDFLAGS -Wl,-z,lazy"
++ AC_MSG_RESULT([yes])
++ ;;
++*)
++ AC_MSG_RESULT([no])
++ ;;
++esac
++
+ AC_OUTPUT([
+ Makefile
+ codegen/Makefile